summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGard Spreemann <gspreemann@gmail.com>2017-02-09 23:40:04 +0100
committerGard Spreemann <gspreemann@gmail.com>2017-02-09 23:40:04 +0100
commit9f6e9a51c2fba32ea2373aee7e2879c22bb8a0e5 (patch)
treec24d7e4d71f642292fc2d40202a23dd9c44cd1d4
parentcb10b2712269194fe151a48a88ed607732945ad2 (diff)
Build documentation package libgudhi-doc.
-rw-r--r--debian/control27
-rw-r--r--debian/libgudhi-doc.install1
-rwxr-xr-xdebian/rules10
3 files changed, 31 insertions, 7 deletions
diff --git a/debian/control b/debian/control
index 7fb33657..efa3a993 100644
--- a/debian/control
+++ b/debian/control
@@ -3,10 +3,11 @@ Maintainer: Gard Spreemann <gspreemann@gmail.com>
Section: math
Priority: optional
Standards-Version: 3.9.8.0
-Build-Depends: cmake (>= 2.6), debhelper (>= 10), libboost-chrono-dev (>= 1.48),
- libboost-filesystem-dev (>= 1.48), libboost-program-options-dev (>= 1.48),
- libboost-system-dev (>= 1.48), libboost-timer-dev (>= 1.48),
- libcgal-dev (>= 4.7), libeigen3-dev (>= 3.1.0), libgmp-dev (>= 4.2), libtbb-dev
+Build-Depends: cmake (>= 2.6), debhelper (>= 10), doxygen, graphviz,
+ libboost-chrono-dev (>= 1.48), libboost-filesystem-dev (>= 1.48),
+ libboost-program-options-dev (>= 1.48), libboost-system-dev (>= 1.48),
+ libboost-timer-dev (>= 1.48), libcgal-dev (>= 4.7), libeigen3-dev (>= 3.1.0),
+ libgmp-dev (>= 4.2), libtbb-dev, texlive-science
Homepage: http://gudhi.gforge.inria.fr/
Vcs-Browser: https://git.nonempty.org/debian-gudhi
Vcs-Git: http://git.nonempty.org/debian-gudhi -b debian/sid
@@ -19,6 +20,7 @@ Depends: ${misc:Depends}, libboost-chrono-dev (>= 1.48),
libboost-filesystem-dev (>= 1.48), libboost-program-options-dev (>= 1.48),
libboost-system-dev (>= 1.48), libboost-timer-dev (>= 1.48),
libcgal-dev (>= 4.7), libeigen3-dev (>= 3.1.0), libgmp-dev (>= 4.2), libtbb-dev
+Suggests: libgudhi-doc
Description: Generic open source C++ library for Topological Data Analysis
The GUDHI library is a generic open source C++ library for
Topological Data Analysis (TDA) and Higher Dimensional Geometry
@@ -31,3 +33,20 @@ Description: Generic open source C++ library for Topological Data Analysis
.
The package currently does not ship any examples. For those, see the
upstream website.
+
+Package: libgudhi-doc
+Section: doc
+Architecture: all
+Multi-Arch: foreign
+Depends: ${misc:Depends}
+Description: Generic open source C++ library for Topological Data Analysis
+ The GUDHI library is a generic open source C++ library for
+ Topological Data Analysis (TDA) and Higher Dimensional Geometry
+ Understanding. The library offers state-of-the-art data structures
+ and algorithms to construct simplicial complexes and compute
+ persistent homology.
+ .
+ The GUDHI library is developed as part of the GUDHI project supported
+ by the European Research Council.
+ .
+ This package contains documentation for the package.
diff --git a/debian/libgudhi-doc.install b/debian/libgudhi-doc.install
new file mode 100644
index 00000000..e3362a5f
--- /dev/null
+++ b/debian/libgudhi-doc.install
@@ -0,0 +1 @@
+doc/html/* usr/share/doc/libgudhi/html/ \ No newline at end of file
diff --git a/debian/rules b/debian/rules
index 966071e5..2bfc3eeb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,14 +6,18 @@ CXXFLAGS:=$(shell dpkg-buildflags --get CXXFLAGS)
LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
%:
- dh $@
+# The --buildirectory=build is there so that we can easily get a hold
+# of documentation and examples, which are not installed by upstream.
+ dh $@ --builddirectory=build
override_dh_auto_clean:
rm -f GUDHIVersion.cmake
+ rm -rf doc/html
dh_auto_clean
-override_dh_auto_install:
- dh_auto_install --destdir=debian/tmp/
+override_dh_auto_build:
+ make -C build doxygen
+ dh_auto_build