summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2020-01-03 11:12:06 +0100
committerGard Spreemann <gspr@nonempty.org>2020-01-03 12:56:17 +0100
commita11db9cb0c8b35fa393c95d698754bb0c652b1d6 (patch)
treed62f6847fe6947f711030e29da4cf7dc2598d14c
parent5031a8bb2704fe329661e58d22e4610d1c02f7f7 (diff)
Allow forcing parallel builds.
-rw-r--r--debian/changelog8
-rwxr-xr-xdebian/rules13
2 files changed, 18 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 728c46b4..9e76122a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+gudhi (3.0.0+dfsg-5) UNRELEASED; urgency=medium
+
+ * Allow forcing parallel builds for local use.
+
+ -- Gard Spreemann <gspr@nonempty.org> Fri, 03 Jan 2020 11:10:44 +0100
+
gudhi (3.0.0+dfsg-4) unstable; urgency=medium
* Drop 0003-Don-t-set-runtime-library-dirs-for-Python-extensions.patch
@@ -115,4 +121,4 @@ gudhi (2.1.0+dfsg-1) unstable; urgency=medium
* Initial packaging. (Closes: #840686)
- -- Gard Spreemann <gspreemann@gmail.com> Sun, 25 Mar 2018 23:52:14 +0200 \ No newline at end of file
+ -- Gard Spreemann <gspreemann@gmail.com> Sun, 25 Mar 2018 23:52:14 +0200
diff --git a/debian/rules b/debian/rules
index 182165f3..c7a9cbef 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,13 +11,22 @@ PY3VERS:=$(shell py3versions -vs)
DEFAULT_PY3VER=$(shell py3versions -vd)
REMAINING_PY3VERS:=$(filter-out $(DEFAULT_PY3VER), $(PY3VERS))
-DHFLAGS+=--buildsystem=cmake --no-parallel
+DHFLAGS+=--buildsystem=cmake
+
+# To fix #945226, we turn off parallel builds everywhere, except if
+# someone explicitly wants them enabled by setting the enivronment
+# variable ALLOW_PARALLEL.
+ifeq (, $(ALLOW_PARALLEL))
+ DHFLAGS+=--no-parallel
+endif
# The buildds run out of memory on some architectures. On those, we
# force non-parallel building.
ifneq (, $(filter $(shell dpkg-architecture --query DEB_BUILD_ARCH),i386 mips mipsel m68k powerpcspe x32))
export DEB_CXXFLAGS_MAINT_APPEND = --param ggc-min-expand=5
- DHFLAGS+=--no-parallel
+# We have disabled parallel builds in general now. Consider disabling
+# for certain architectures if it's reenabled globally.
+# DHFLAGS+=--no-parallel
endif
# Disable tests on i386 due to rounding problem in some. See upstream GitHub issue #118.