summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2020-08-10 08:53:42 +0200
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2020-08-10 08:53:42 +0200
commita73448292bf41a6af928f649905e2ceeca199c24 (patch)
tree1b73f36c519ba9eccc26f5bf7a53d13af8cc4cfd
parent2475e9ec590ae36d8b5f76216f6575c371b76165 (diff)
Some cleanups before the merge
-rw-r--r--.github/workflows/pip-packaging-windows.yml25
1 files changed, 9 insertions, 16 deletions
diff --git a/.github/workflows/pip-packaging-windows.yml b/.github/workflows/pip-packaging-windows.yml
index 2d1058fe..2e45ad71 100644
--- a/.github/workflows/pip-packaging-windows.yml
+++ b/.github/workflows/pip-packaging-windows.yml
@@ -1,15 +1,8 @@
name: pip packaging windows
-#on:
-# release:
-# types: [published]
-
-on:
- push:
- branches:
- - '*'
- - '*/*'
- - '**'
+on:
+ release:
+ types: [published]
jobs:
build:
@@ -40,7 +33,7 @@ jobs:
python -m pip install --user -r .github/build-requirements.txt
python -m pip install --user twine
python -m pip list
- - name: Build wheels
+ - name: Build python wheel
run: |
mkdir build
cd build
@@ -49,8 +42,8 @@ jobs:
cp c:/vcpkg/installed/x64-windows/bin/mpfr.dll gudhi/
cp c:/vcpkg/installed/x64-windows/bin/mpir.dll gudhi/
python setup.py bdist_wheel
-# - name: Publish on PyPi
-# env:
-# TWINE_USERNAME: __token__
-# TWINE_PASSWORD: ${{ secrets.PYPI_PASSWORD }}
-# run: python -m twine upload build/src/python/dist/*
+ - name: Publish on PyPi
+ env:
+ TWINE_USERNAME: __token__
+ TWINE_PASSWORD: ${{ secrets.PYPI_PASSWORD }}
+ run: python -m twine upload build/src/python/dist/*