summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-08-31 12:38:13 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-08-31 12:38:13 +0000
commitec9100908202bb5b7a6ba835edeabf3272d70e98 (patch)
treea1c0e991056933d30d1f70d72d3ad593e4e2c631
parent6a52e22654a677f087267226366de02ab7bb7527 (diff)
Link with release third parties library version, even in debug mode
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/trunk@3863 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: e33e15081b3029d9dfd4edc464d91b0db47e1754
-rw-r--r--src/cython/CMakeLists.txt13
1 files changed, 2 insertions, 11 deletions
diff --git a/src/cython/CMakeLists.txt b/src/cython/CMakeLists.txt
index 90a2fcf7..cf57d872 100644
--- a/src/cython/CMakeLists.txt
+++ b/src/cython/CMakeLists.txt
@@ -130,11 +130,7 @@ if(CYTHON_FOUND)
if(CGAL_FOUND)
can_cgal_use_cxx11_thread_local()
if (NOT CGAL_CAN_USE_CXX11_THREAD_LOCAL_RESULT)
- if(CMAKE_BUILD_TYPE MATCHES Debug)
- add_gudhi_cython_lib("${Boost_THREAD_LIBRARY_DEBUG}")
- else()
- add_gudhi_cython_lib("${Boost_THREAD_LIBRARY_RELEASE}")
- endif()
+ add_gudhi_cython_lib("${Boost_THREAD_LIBRARY_RELEASE}")
set(GUDHI_CYTHON_LIBRARY_DIRS "${GUDHI_CYTHON_LIBRARY_DIRS}'${Boost_LIBRARY_DIRS}', ")
endif()
# Add CGAL compilation args
@@ -143,15 +139,10 @@ if(CYTHON_FOUND)
set(GUDHI_CYTHON_EXTRA_COMPILE_ARGS "${GUDHI_CYTHON_EXTRA_COMPILE_ARGS}'-DCGAL_HEADER_ONLY', ")
else(CGAL_HEADER_ONLY)
add_gudhi_debug_info("CGAL version ${CGAL_VERSION}")
- add_gudhi_cython_lib("${CGAL_LIBRARIES}")
add_gudhi_cython_lib("${CGAL_LIBRARY}")
set(GUDHI_CYTHON_LIBRARY_DIRS "${GUDHI_CYTHON_LIBRARY_DIRS}'${CGAL_LIBRARIES_DIR}', ")
# If CGAL is not header only, CGAL library may link with boost system,
- if(CMAKE_BUILD_TYPE MATCHES Debug)
- add_gudhi_cython_lib("${Boost_SYSTEM_LIBRARY_DEBUG}")
- else()
- add_gudhi_cython_lib("${Boost_SYSTEM_LIBRARY_RELEASE}")
- endif()
+ add_gudhi_cython_lib("${Boost_SYSTEM_LIBRARY_RELEASE}")
set(GUDHI_CYTHON_LIBRARY_DIRS "${GUDHI_CYTHON_LIBRARY_DIRS}'${Boost_LIBRARY_DIRS}', ")
endif(CGAL_HEADER_ONLY)
# GMP and GMPXX are not required, but if present, CGAL will link with them.