summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcjamin <cjamin@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-08-27 08:03:05 +0000
committercjamin <cjamin@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-08-27 08:03:05 +0000
commitf4a89213f0a66b6aff58ab4a39d53e43592bde7f (patch)
tree54e0fd069ea7fd8c6e849f278c373cbaa961190d
parentf0977e3b6eadaaccba55e01b0c148c1b7493f3bd (diff)
Merge from trunk + minor fix in doc
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/subsampling_and_spatialsearching@1457 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 961641cb06e1d694f5e733b1677133e8fef25d22
-rw-r--r--src/Persistent_cohomology/example/CMakeLists.txt10
-rw-r--r--src/Persistent_cohomology/include/gudhi/Persistent_cohomology.h6
-rw-r--r--src/Spatial_searching/doc/Intro_spatial_searching.h2
3 files changed, 9 insertions, 9 deletions
diff --git a/src/Persistent_cohomology/example/CMakeLists.txt b/src/Persistent_cohomology/example/CMakeLists.txt
index d6bc60be..d97d1b63 100644
--- a/src/Persistent_cohomology/example/CMakeLists.txt
+++ b/src/Persistent_cohomology/example/CMakeLists.txt
@@ -37,11 +37,11 @@ add_test(persistence_from_file_3_3_100 ${CMAKE_CURRENT_BINARY_DIR}/persistence_f
if(GMP_FOUND)
if(GMPXX_FOUND)
- add_executable(rips_multifield_persistence rips_multifield_persistence.cpp )
- target_link_libraries(rips_multifield_persistence ${Boost_SYSTEM_LIBRARY} ${Boost_PROGRAM_OPTIONS_LIBRARY} ${GMPXX_LIBRARIES} ${GMP_LIBRARIES})
- add_executable ( performance_rips_persistence performance_rips_persistence.cpp )
- target_link_libraries(performance_rips_persistence ${Boost_SYSTEM_LIBRARY} ${Boost_PROGRAM_OPTIONS_LIBRARY} ${GMPXX_LIBRARIES} ${GMP_LIBRARIES})
- if (TBB_FOUND)
+ add_executable(rips_multifield_persistence rips_multifield_persistence.cpp )
+ target_link_libraries(rips_multifield_persistence ${Boost_SYSTEM_LIBRARY} ${Boost_PROGRAM_OPTIONS_LIBRARY} ${GMPXX_LIBRARIES} ${GMP_LIBRARIES})
+ add_executable ( performance_rips_persistence performance_rips_persistence.cpp )
+ target_link_libraries(performance_rips_persistence ${Boost_SYSTEM_LIBRARY} ${Boost_PROGRAM_OPTIONS_LIBRARY} ${GMPXX_LIBRARIES} ${GMP_LIBRARIES})
+ if (TBB_FOUND)
target_link_libraries(rips_multifield_persistence ${TBB_LIBRARIES})
target_link_libraries(performance_rips_persistence ${TBB_LIBRARIES})
endif(TBB_FOUND)
diff --git a/src/Persistent_cohomology/include/gudhi/Persistent_cohomology.h b/src/Persistent_cohomology/include/gudhi/Persistent_cohomology.h
index b6cef611..a7d1e463 100644
--- a/src/Persistent_cohomology/include/gudhi/Persistent_cohomology.h
+++ b/src/Persistent_cohomology/include/gudhi/Persistent_cohomology.h
@@ -308,14 +308,14 @@ class Persistent_cohomology {
// Find its annotation vector
curr_col = ds_repr_[dsets_.find_set(key)];
if (curr_col != NULL) { // and insert it in annotations_in_boundary with multyiplicative factor "sign".
- annotations_in_boundary.emplace_back(curr_col, sign);
+ annotations_in_boundary.emplace_back(curr_col, sign);
}
}
sign = -sign;
}
// Place identical annotations consecutively so we can easily sum their multiplicities.
std::sort(annotations_in_boundary.begin(), annotations_in_boundary.end(),
- [](annotation_t const& a, annotation_t const& b) { return a.first < b.first; });
+ [](annotation_t const& a, annotation_t const& b) { return a.first < b.first; });
// Sum the annotations with multiplicity, using a map<key,coeff>
// to represent a sparse vector.
@@ -325,7 +325,7 @@ class Persistent_cohomology {
Column* col = ann_it->first;
int mult = ann_it->second;
while (++ann_it != annotations_in_boundary.end() && ann_it->first == col) {
- mult += ann_it->second;
+ mult += ann_it->second;
}
// The following test is just a heuristic, it is not required, and it is fine that is misses p == 0.
if (mult != coeff_field_.additive_identity()) { // For all columns in the boundary,
diff --git a/src/Spatial_searching/doc/Intro_spatial_searching.h b/src/Spatial_searching/doc/Intro_spatial_searching.h
index 20b262d9..2406c931 100644
--- a/src/Spatial_searching/doc/Intro_spatial_searching.h
+++ b/src/Spatial_searching/doc/Intro_spatial_searching.h
@@ -37,7 +37,7 @@ namespace spatial_searching {
*
* This Gudhi component is a wrapper around
* <a target="_blank" href="http://doc.cgal.org/latest/Spatial_searching/index.html">CGAL dD spatial searching algorithms</a>.
- * It provides a simplified API to perform (approximate) nearest neighbor searches. Contrary to CGAL default behavior, the tree
+ * It provides a simplified API to perform (approximate) neighbor searches. Contrary to CGAL default behavior, the tree
* does not store the points themselves, but stores indices.
*
* \section spatial_searching_examples Example