summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVincent Rouvreau <10407034+VincentRouvreau@users.noreply.github.com>2022-12-02 09:44:59 +0100
committerGitHub <noreply@github.com>2022-12-02 09:44:59 +0100
commit04e050b019c1bdfdd0de3f79fda017ed2da70fe7 (patch)
treef8909cfcdb195072a83ac9b1c58e17aacc3a5e82
parent5d0c294572a9e34a7a70e78806ac3cf805357712 (diff)
parent7637d0e1d07144631bf7c22bbec5356a7376fc11 (diff)
Merge pull request #760 from VincentRouvreau/ci/circleci_python_test
[CI] python ctest was not launched for python circleci job
-rw-r--r--.circleci/config.yml1
1 files changed, 1 insertions, 0 deletions
diff --git a/.circleci/config.yml b/.circleci/config.yml
index c8c0b70b..b59b7562 100644
--- a/.circleci/config.yml
+++ b/.circleci/config.yml
@@ -82,6 +82,7 @@ jobs:
cmake -DCMAKE_BUILD_TYPE=Release -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=ON -DPython_ADDITIONAL_VERSIONS=3 -DWITH_GUDHI_REMOTE_TEST=ON .
cd python
python3 setup.py build_ext --inplace
+ ctest --output-on-failure
make sphinx
cp -R sphinx /tmp/sphinx
python3 setup.py install