summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVincent Rouvreau <10407034+VincentRouvreau@users.noreply.github.com>2021-01-05 19:23:59 +0100
committerGitHub <noreply@github.com>2021-01-05 19:23:59 +0100
commitca18cc5ab72eaf133adcd8b5bcde794ff8166384 (patch)
treebc16815814fdff00e1f19226c33e0ec02cb15b0d
parent6c1686e77b066525cd08d1d6f4c8e220bfef2c48 (diff)
parent5f6bf9af6b9036f41a3430527e73a3e1cd733e2b (diff)
Merge pull request #445 from VincentRouvreau/gudhi_3_4_1_rc_1
gudhi 3.4.1rc 1
-rw-r--r--.appveyor.yml2
-rw-r--r--CMakeGUDHIVersion.txt4
-rw-r--r--azure-pipelines.yml2
3 files changed, 4 insertions, 4 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index a257debc..06de5b14 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -60,7 +60,7 @@ build_script:
cd src/python &
type setup.py &
MSBuild Cython.sln /m /p:Configuration=Release /p:Platform=x64 &
- ctest -j 1 --output-on-failure -C Release
+ ctest -j 1 --output-on-failure -C Release -E sphinx
) else (
MSBuild GUDHIdev.sln /m /p:Configuration=Release /p:Platform=x64 &
ctest -j 1 --output-on-failure -C Release -E diff_files
diff --git a/CMakeGUDHIVersion.txt b/CMakeGUDHIVersion.txt
index db9b243b..11c8766b 100644
--- a/CMakeGUDHIVersion.txt
+++ b/CMakeGUDHIVersion.txt
@@ -1,8 +1,8 @@
# Must be conform to pep440 - https://www.python.org/dev/peps/pep-0440/#pre-releases
set (GUDHI_MAJOR_VERSION 3)
-set (GUDHI_MINOR_VERSION 5)
+set (GUDHI_MINOR_VERSION 4)
# GUDHI_PATCH_VERSION can be 'ZaN' for Alpha release, 'ZbN' for Beta release, 'ZrcN' for release candidate or 'Z' for a final release.
-set (GUDHI_PATCH_VERSION 0rc1)
+set (GUDHI_PATCH_VERSION 1rc1)
set(GUDHI_VERSION ${GUDHI_MAJOR_VERSION}.${GUDHI_MINOR_VERSION}.${GUDHI_PATCH_VERSION})
message(STATUS "GUDHI version : ${GUDHI_VERSION}")
diff --git a/azure-pipelines.yml b/azure-pipelines.yml
index 8e88cab5..64f3d141 100644
--- a/azure-pipelines.yml
+++ b/azure-pipelines.yml
@@ -33,5 +33,5 @@ jobs:
cmake -DCMAKE_BUILD_TYPE:STRING=$(cmakeBuildType) -DWITH_GUDHI_TEST=ON -DWITH_GUDHI_UTILITIES=ON -DWITH_GUDHI_PYTHON=ON -DPython_ADDITIONAL_VERSIONS=3 ..
make -j 4
make doxygen
- ctest -j 4 --output-on-failure # -E sphinx remove sphinx build as it fails
+ ctest -j 4 --output-on-failure -E sphinx # remove sphinx build as it fails
displayName: 'Build, test and documentation generation'