summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGard Spreemann <gspreemann@gmail.com>2018-05-24 11:25:19 +0200
committerGard Spreemann <gspreemann@gmail.com>2018-05-24 11:25:19 +0200
commit06754c9bf5dfb1c5aa2809817aaeba5c41708992 (patch)
tree95eaaa05b8dea6263bcdd31e1c78168bdba9196c
parent332e7cf49db86a9cca6931126fd78a4a96fa5725 (diff)
Patch to force linking of the Python module with CGAL. Upstream's method stopped working with CGAL 4.12.
-rw-r--r--debian/patches/0008-Force-linking-of-Python-module-with-CGAL.patch21
-rw-r--r--debian/patches/series1
2 files changed, 22 insertions, 0 deletions
diff --git a/debian/patches/0008-Force-linking-of-Python-module-with-CGAL.patch b/debian/patches/0008-Force-linking-of-Python-module-with-CGAL.patch
new file mode 100644
index 00000000..2b3a91ba
--- /dev/null
+++ b/debian/patches/0008-Force-linking-of-Python-module-with-CGAL.patch
@@ -0,0 +1,21 @@
+From: Gard Spreemann <gspreemann@gmail.com>
+Date: Thu, 24 May 2018 11:24:43 +0200
+Subject: Force linking of Python module with CGAL.
+
+---
+ cython/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cython/CMakeLists.txt b/cython/CMakeLists.txt
+index ec3cb8f..87b2846 100644
+--- a/cython/CMakeLists.txt
++++ b/cython/CMakeLists.txt
+@@ -103,7 +103,7 @@ if(CYTHON_FOUND)
+ if(CGAL_HEADER_ONLY)
+ set(GUDHI_CYTHON_EXTRA_COMPILE_ARGS "${GUDHI_CYTHON_EXTRA_COMPILE_ARGS}'-DCGAL_HEADER_ONLY', ")
+ else(CGAL_HEADER_ONLY)
+- add_gudhi_cython_lib(${CGAL_LIBRARIES})
++ add_gudhi_cython_lib("${CGAL_LIBRARIES_DIR}/libCGAL.so")
+ set(GUDHI_CYTHON_LIBRARY_DIRS "${GUDHI_CYTHON_LIBRARY_DIRS}'${CGAL_LIBRARIES_DIR}', ")
+ # If CGAL is not header only, CGAL library may link with boost system,
+ add_gudhi_cython_lib(${Boost_SYSTEM_LIBRARY})
diff --git a/debian/patches/series b/debian/patches/series
index 6a2bbf20..6178386d 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -5,3 +5,4 @@
0005-Don-t-set-runtime_library_dirs-for-the-Python-extens.patch
no-external-doc-resources.patch
0007-CGAL-4.12-compatibility.patch
+0008-Force-linking-of-Python-module-with-CGAL.patch