summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGard Spreemann <gspreemann@gmail.com>2018-08-12 12:38:28 +0200
committerGard Spreemann <gspreemann@gmail.com>2018-08-12 12:38:28 +0200
commit5bddbbf576ca35a2eff6fd58a0eba6f5b4491ae8 (patch)
tree4a6a1dcf168ad7a1efb9a550109abd8e6d586990
parent757b0308369060bb1395600c67041c6d78bd65bc (diff)
Build default Python version binding first to ease debugging.
-rwxr-xr-xdebian/rules6
1 files changed, 3 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 09505a60..64c541d2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,8 +8,8 @@ LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
TMPBIN:=debian/tmp/usr/bin
PY3VERS:=$(shell py3versions -vs)
-FIRST_PY3VER:=$(word 1, $(PY3VERS))
-REMAINING_PY3VERS:=$(filter-out $(FIRST_PY3VER), $(PY3VERS))
+DEFAULT_PY3VER=$(shell py3versions -vd)
+REMAINING_PY3VERS:=$(filter-out $(DEFAULT_PY3VER), $(PY3VERS))
%:
# The --buildirectory=build is there so that we can easily get a hold
@@ -20,7 +20,7 @@ REMAINING_PY3VERS:=$(filter-out $(FIRST_PY3VER), $(PY3VERS))
done
override_dh_auto_configure:
- dh_auto_configure -- -DWITH_GUDHI_BENCHMARK=true -DWITH_GUDHI_EXAMPLE=true -DWITH_GUDHI_PYTHON=true -DWITH_GUDHI_TEST=true -DWITH_GUDHI_UTILITIES=true -DPython_ADDITIONAL_VERSIONS=$(FIRST_PY3VER)
+ dh_auto_configure -- -DWITH_GUDHI_BENCHMARK=true -DWITH_GUDHI_EXAMPLE=true -DWITH_GUDHI_PYTHON=true -DWITH_GUDHI_TEST=true -DWITH_GUDHI_UTILITIES=true -DPython_ADDITIONAL_VERSIONS=$(DEFAULT_PY3VER)
for py3ver in $(REMAINING_PY3VERS) ; do \
dh_auto_configure --builddirectory=build$$py3ver -- -DWITH_GUDHI_BENCHMARK=false -DWITH_GUDHI_EXAMPLE=false -DWITH_GUDHI_PYTHON=true -DWITH_GUDHI_TEST=true -DWITH_GUDHI_UTILITIES=false -DPython_ADDITIONAL_VERSIONS=$$py3ver ; \
done