summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGard Spreemann <gspreemann@gmail.com>2018-06-15 13:38:49 +0200
committerGard Spreemann <gspreemann@gmail.com>2018-06-15 13:38:49 +0200
commit7441f013f50f613b1a9c0e7a9bff697df442a78e (patch)
treecf06e0c7d4208be867e99e1d9e759c33333a9d39
parent7fb542259cf26331d7ad74da4bc89f16ad4912b3 (diff)
Refresh patches. The i686 rounding workaround and CGAL 4.12 compatibility patches dropped.
-rw-r--r--debian/patches/0001-Force-Python-3-detection.patch32
-rw-r--r--debian/patches/0002-Disable-Sphinx-test-since-we-re-not-currently-using.patch23
-rw-r--r--debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch77
-rw-r--r--debian/patches/0004-Use-system-MathJax.patch21
-rw-r--r--debian/patches/0005-Don-t-set-runtime-library-dirs-for-Python-extensions.patch21
-rw-r--r--debian/patches/0006-Force-linking-of-Python-module-with-CGAL.patch21
-rw-r--r--debian/patches/0007-Force-linking-against-libatomic-for-parts-that-use-T.patch21
-rw-r--r--debian/patches/series7
8 files changed, 223 insertions, 0 deletions
diff --git a/debian/patches/0001-Force-Python-3-detection.patch b/debian/patches/0001-Force-Python-3-detection.patch
new file mode 100644
index 00000000..828025a6
--- /dev/null
+++ b/debian/patches/0001-Force-Python-3-detection.patch
@@ -0,0 +1,32 @@
+From: Gard Spreemann <gspreemann@gmail.com>
+Date: Fri, 15 Jun 2018 13:17:30 +0200
+Subject: Force Python 3 detection.
+
+---
+ cmake/modules/FindCython.cmake | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/cmake/modules/FindCython.cmake b/cmake/modules/FindCython.cmake
+index 04aed1f..f3a5b7b 100644
+--- a/cmake/modules/FindCython.cmake
++++ b/cmake/modules/FindCython.cmake
+@@ -24,16 +24,16 @@
+
+ # Use the Cython executable that lives next to the Python executable
+ # if it is a local installation.
+-find_package( PythonInterp )
++find_package( PythonInterp 3 )
+ if( PYTHONINTERP_FOUND )
+ get_filename_component( _python_path ${PYTHON_EXECUTABLE} PATH )
+ find_program( CYTHON_EXECUTABLE
+- NAMES cython cython.bat cython3
++ NAMES cython3
+ HINTS ${_python_path}
+ )
+ else()
+ find_program( CYTHON_EXECUTABLE
+- NAMES cython cython.bat cython3
++ NAMES cython3
+ )
+ endif()
+
diff --git a/debian/patches/0002-Disable-Sphinx-test-since-we-re-not-currently-using.patch b/debian/patches/0002-Disable-Sphinx-test-since-we-re-not-currently-using.patch
new file mode 100644
index 00000000..abf2a450
--- /dev/null
+++ b/debian/patches/0002-Disable-Sphinx-test-since-we-re-not-currently-using.patch
@@ -0,0 +1,23 @@
+From: Gard Spreemann <gspreemann@gmail.com>
+Date: Fri, 15 Jun 2018 13:18:26 +0200
+Subject: Disable Sphinx test since we're not currently using.
+
+---
+ cython/CMakeLists.txt | 5 -----
+ 1 file changed, 5 deletions(-)
+
+diff --git a/cython/CMakeLists.txt b/cython/CMakeLists.txt
+index 17d440e..9194e45 100644
+--- a/cython/CMakeLists.txt
++++ b/cython/CMakeLists.txt
+@@ -280,10 +280,5 @@ if(CYTHON_FOUND)
+ DEPENDS "${CMAKE_CURRENT_BINARY_DIR}/gudhi.so"
+ COMMENT "${GUDHI_SPHINX_MESSAGE}" VERBATIM)
+
+- add_test(NAME sphinx_py_test
+- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+- COMMAND ${CMAKE_COMMAND} -E env "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}"
+- ${SPHINX_PATH} -b doctest ${CMAKE_CURRENT_SOURCE_DIR}/doc ${CMAKE_CURRENT_BINARY_DIR}/doctest)
+-
+ endif(SPHINX_PATH AND NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)
+ endif(CYTHON_FOUND)
diff --git a/debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch b/debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch
new file mode 100644
index 00000000..3f5fb5bb
--- /dev/null
+++ b/debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch
@@ -0,0 +1,77 @@
+From: Gard Spreemann <gspreemann@gmail.com>
+Date: Fri, 15 Jun 2018 13:19:42 +0200
+Subject: Disable tests that use DFSG-deleted data files.
+
+---
+ example/Nerve_GIC/CMakeLists.txt | 6 ------
+ example/Persistent_cohomology/CMakeLists.txt | 4 ----
+ example/Simplex_tree/CMakeLists.txt | 2 --
+ utilities/Nerve_GIC/CMakeLists.txt | 6 ------
+ 4 files changed, 18 deletions(-)
+
+diff --git a/example/Nerve_GIC/CMakeLists.txt b/example/Nerve_GIC/CMakeLists.txt
+index fdecf86..f63e08e 100644
+--- a/example/Nerve_GIC/CMakeLists.txt
++++ b/example/Nerve_GIC/CMakeLists.txt
+@@ -12,16 +12,10 @@ if (NOT CGAL_VERSION VERSION_LESS 4.8.1)
+
+ # Copy files for not to pollute sources when testing
+ file(COPY "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+
+ add_test(NAME Nerve_GIC_example_CoordGIC COMMAND $<TARGET_FILE:CoordGIC>
+ "${CMAKE_CURRENT_BINARY_DIR}/tore3D_1307.off" "0")
+
+- add_test(NAME Nerve_GIC_example_FuncGIC COMMAND $<TARGET_FILE:FuncGIC>
+- "${CMAKE_CURRENT_BINARY_DIR}/lucky_cat.off"
+- "${CMAKE_CURRENT_BINARY_DIR}/lucky_cat_PCA1")
+-
+ install(TARGETS CoordGIC DESTINATION bin)
+ install(TARGETS FuncGIC DESTINATION bin)
+
+diff --git a/example/Persistent_cohomology/CMakeLists.txt b/example/Persistent_cohomology/CMakeLists.txt
+index 0f73151..4cac586 100644
+--- a/example/Persistent_cohomology/CMakeLists.txt
++++ b/example/Persistent_cohomology/CMakeLists.txt
+@@ -28,10 +28,6 @@ add_test(NAME Persistent_cohomology_example_from_rips_step_by_step_on_tore_3D CO
+ "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" "-r" "0.25" "-m" "0.5" "-d" "3" "-p" "3")
+ add_test(NAME Persistent_cohomology_example_via_boundary_matrix COMMAND $<TARGET_FILE:rips_persistence_via_boundary_matrix>
+ "${CMAKE_SOURCE_DIR}/data/points/Kl.off" "-r" "0.16" "-d" "3" "-p" "3" "-m" "100")
+-add_test(NAME Persistent_cohomology_example_from_file_3_2_0 COMMAND $<TARGET_FILE:persistence_from_file>
+- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "2" "-m" "0")
+-add_test(NAME Persistent_cohomology_example_from_file_3_3_100 COMMAND $<TARGET_FILE:persistence_from_file>
+- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "3" "-m" "100")
+
+ install(TARGETS plain_homology DESTINATION bin)
+ install(TARGETS persistence_from_simple_simplex_tree DESTINATION bin)
+diff --git a/example/Simplex_tree/CMakeLists.txt b/example/Simplex_tree/CMakeLists.txt
+index 857e851..48bb069 100644
+--- a/example/Simplex_tree/CMakeLists.txt
++++ b/example/Simplex_tree/CMakeLists.txt
+@@ -29,8 +29,6 @@ if(GMP_FOUND AND CGAL_FOUND)
+ if (TBB_FOUND)
+ target_link_libraries(Simplex_tree_example_alpha_shapes_3_from_off ${TBB_LIBRARIES})
+ endif()
+- add_test(NAME Simplex_tree_example_alpha_shapes_3_from_off COMMAND $<TARGET_FILE:Simplex_tree_example_alpha_shapes_3_from_off>
+- "${CMAKE_SOURCE_DIR}/data/points/bunny_5000.off")
+
+ install(TARGETS Simplex_tree_example_alpha_shapes_3_from_off DESTINATION bin)
+
+diff --git a/utilities/Nerve_GIC/CMakeLists.txt b/utilities/Nerve_GIC/CMakeLists.txt
+index 215f9df..266171d 100644
+--- a/utilities/Nerve_GIC/CMakeLists.txt
++++ b/utilities/Nerve_GIC/CMakeLists.txt
+@@ -14,12 +14,6 @@ if (NOT CGAL_VERSION VERSION_LESS 4.8.1)
+ # Copy files for not to pollute sources when testing
+ file(COPY "${CMAKE_SOURCE_DIR}/data/points/human.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+
+- add_test(NAME Nerve_GIC_utilities_nerve COMMAND $<TARGET_FILE:Nerve>
+- "human.off" "2" "10" "0.3")
+-
+- add_test(NAME Nerve_GIC_utilities_VoronoiGIC COMMAND $<TARGET_FILE:VoronoiGIC>
+- "human.off" "100")
+-
+ install(TARGETS Nerve DESTINATION bin)
+ install(TARGETS VoronoiGIC DESTINATION bin)
+ install(FILES KeplerMapperVisuFromTxtFile.py km.py km.py.COPYRIGHT DESTINATION bin)
diff --git a/debian/patches/0004-Use-system-MathJax.patch b/debian/patches/0004-Use-system-MathJax.patch
new file mode 100644
index 00000000..ecd7b0d3
--- /dev/null
+++ b/debian/patches/0004-Use-system-MathJax.patch
@@ -0,0 +1,21 @@
+From: Gard Spreemann <gspreemann@gmail.com>
+Date: Fri, 15 Jun 2018 13:20:33 +0200
+Subject: Use system MathJax.
+
+---
+ Doxyfile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Doxyfile b/Doxyfile
+index 020667e..88ce932 100644
+--- a/Doxyfile
++++ b/Doxyfile
+@@ -1454,7 +1454,7 @@ MATHJAX_FORMAT = HTML-CSS
+ # The default value is: http://cdn.mathjax.org/mathjax/latest.
+ # This tag requires that the tag USE_MATHJAX is set to YES.
+
+-MATHJAX_RELPATH = ../common
++MATHJAX_RELPATH = /usr/share/javascript/mathjax
+
+ # The MATHJAX_EXTENSIONS tag can be used to specify one or more MathJax
+ # extension names that should be enabled during MathJax rendering. For example
diff --git a/debian/patches/0005-Don-t-set-runtime-library-dirs-for-Python-extensions.patch b/debian/patches/0005-Don-t-set-runtime-library-dirs-for-Python-extensions.patch
new file mode 100644
index 00000000..5ab944f7
--- /dev/null
+++ b/debian/patches/0005-Don-t-set-runtime-library-dirs-for-Python-extensions.patch
@@ -0,0 +1,21 @@
+From: Gard Spreemann <gspreemann@gmail.com>
+Date: Fri, 15 Jun 2018 13:21:25 +0200
+Subject: Don't set runtime library dirs for Python extensions.
+
+---
+ cython/setup.py.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cython/setup.py.in b/cython/setup.py.in
+index ee381a1..3c8e0c4 100644
+--- a/cython/setup.py.in
++++ b/cython/setup.py.in
+@@ -36,7 +36,7 @@ gudhi = Extension(
+ libraries=[@GUDHI_CYTHON_LIBRARIES@],
+ library_dirs=[@GUDHI_CYTHON_LIBRARY_DIRS@],
+ include_dirs = [@GUDHI_CYTHON_INCLUDE_DIRS@],
+- runtime_library_dirs=[@GUDHI_CYTHON_RUNTIME_LIBRARY_DIRS@],
++ runtime_library_dirs=[],
+ )
+
+ setup(
diff --git a/debian/patches/0006-Force-linking-of-Python-module-with-CGAL.patch b/debian/patches/0006-Force-linking-of-Python-module-with-CGAL.patch
new file mode 100644
index 00000000..cea5de9d
--- /dev/null
+++ b/debian/patches/0006-Force-linking-of-Python-module-with-CGAL.patch
@@ -0,0 +1,21 @@
+From: Gard Spreemann <gspreemann@gmail.com>
+Date: Fri, 15 Jun 2018 13:23:55 +0200
+Subject: Force linking of Python module with CGAL.
+
+---
+ cython/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cython/CMakeLists.txt b/cython/CMakeLists.txt
+index 9194e45..90ca2b7 100644
+--- a/cython/CMakeLists.txt
++++ b/cython/CMakeLists.txt
+@@ -78,7 +78,7 @@ if(CYTHON_FOUND)
+ if(CGAL_HEADER_ONLY)
+ set(GUDHI_CYTHON_EXTRA_COMPILE_ARGS "${GUDHI_CYTHON_EXTRA_COMPILE_ARGS}'-DCGAL_HEADER_ONLY', ")
+ else(CGAL_HEADER_ONLY)
+- add_gudhi_cython_lib(${CGAL_LIBRARY})
++ add_gudhi_cython_lib("${CGAL_LIBRARIES_DIR}/libCGAL.so")
+ set(GUDHI_CYTHON_LIBRARY_DIRS "${GUDHI_CYTHON_LIBRARY_DIRS}'${CGAL_LIBRARIES_DIR}', ")
+ # If CGAL is not header only, CGAL library may link with boost system,
+ add_gudhi_cython_lib(${Boost_SYSTEM_LIBRARY})
diff --git a/debian/patches/0007-Force-linking-against-libatomic-for-parts-that-use-T.patch b/debian/patches/0007-Force-linking-against-libatomic-for-parts-that-use-T.patch
new file mode 100644
index 00000000..7d69e5ce
--- /dev/null
+++ b/debian/patches/0007-Force-linking-against-libatomic-for-parts-that-use-T.patch
@@ -0,0 +1,21 @@
+From: Gard Spreemann <gspreemann@gmail.com>
+Date: Fri, 15 Jun 2018 13:25:37 +0200
+Subject: Force linking against libatomic for parts that use TBB.
+
+---
+ cmake/modules/FindTBB.cmake | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/cmake/modules/FindTBB.cmake b/cmake/modules/FindTBB.cmake
+index 13f4d92..6baa8d7 100644
+--- a/cmake/modules/FindTBB.cmake
++++ b/cmake/modules/FindTBB.cmake
+@@ -375,6 +375,8 @@ if (TBB_INCLUDE_DIR)
+ endif(NOT TBB_without_pthread)
+ endif(UNIX AND NOT APPLE)
+
++ list(APPEND ALL_TBB_LIBRARIES atomic)
++
+ set (TBB_LIBRARIES ${ALL_TBB_LIBRARIES}
+ CACHE PATH "TBB libraries" FORCE)
+
diff --git a/debian/patches/series b/debian/patches/series
index e69de29b..efd45f90 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -0,0 +1,7 @@
+0001-Force-Python-3-detection.patch
+0002-Disable-Sphinx-test-since-we-re-not-currently-using.patch
+0003-Disable-tests-that-use-DFSG-deleted-data-files.patch
+0004-Use-system-MathJax.patch
+0005-Don-t-set-runtime-library-dirs-for-Python-extensions.patch
+0006-Force-linking-of-Python-module-with-CGAL.patch
+0007-Force-linking-against-libatomic-for-parts-that-use-T.patch