summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGard Spreemann <gspreemann@gmail.com>2018-06-12 10:51:06 +0200
committerGard Spreemann <gspreemann@gmail.com>2018-06-12 11:32:00 +0200
commitb6d352a83740be5ce12e33b0b89980538246a504 (patch)
tree8f7b9a41ec89242bf5112ad1db82c331785138ce
parent9f3023fc3e5cb3fa7073d5b3fa2c7011002af1d1 (diff)
Install utilities (binary gudhi-utils).
-rw-r--r--debian/changelog3
-rw-r--r--debian/control17
-rw-r--r--debian/gudhi-utils.install1
-rwxr-xr-xdebian/rules16
4 files changed, 35 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index aa33626c..e75e09cb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,9 @@
gudhi (2.1.0+dfsg-3) UNRELEASED; urgency=medium
* Add patch for floating point rounding problem on some architectures.
+ * Install utilities (gudhi-utils).
- -- Gard Spreemann <gspreemann@gmail.com> Tue, 12 Jun 2018 10:01:01 +0200
+ -- Gard Spreemann <gspreemann@gmail.com> Tue, 12 Jun 2018 10:50:01 +0200
gudhi (2.1.0+dfsg-2) unstable; urgency=medium
diff --git a/debian/control b/debian/control
index 08695af5..75a8fd73 100644
--- a/debian/control
+++ b/debian/control
@@ -132,3 +132,20 @@ Description: GUI for some of the functionality of the GUDHI library
.
This package contains GudhUI, a graphical interface to a few of GUDHI's
features. Be aware that it is quite rough around the edges.
+
+Package: gudhi-utils
+Section: math
+Architecture: any
+Depends: ${misc:Depends}, ${shlibs:Depends}
+Description: Utilities from the GUDHI library
+ The GUDHI library is a generic open source C++ library for
+ Topological Data Analysis (TDA) and Higher Dimensional Geometry
+ Understanding. The library offers state-of-the-art data structures
+ and algorithms to construct simplicial complexes and compute
+ persistent homology.
+ .
+ The GUDHI library is developed as part of the GUDHI project supported
+ by the European Research Council.
+ .
+ This package contains some utilities built with the GUDHI library.
+ \ No newline at end of file
diff --git a/debian/gudhi-utils.install b/debian/gudhi-utils.install
new file mode 100644
index 00000000..71e8eb9f
--- /dev/null
+++ b/debian/gudhi-utils.install
@@ -0,0 +1 @@
+debian/tmp/usr/bin/gudhi-* usr/bin/
diff --git a/debian/rules b/debian/rules
index 8f15b62f..0b6bfa7a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -22,8 +22,22 @@ override_dh_auto_test:
override_dh_auto_install:
find example -type f \( -name '*.cpp' -o \( -name '*.txt' -a ! -iname 'cmake*' \) \) -exec sh -c 'install -D -m 644 $$0 debian/tmp/usr/share/doc/libgudhi-examples/$$0' {} \;
- install -D build/GudhUI/GudhUI debian/tmp/usr/bin/gudhui
dh_auto_install --builddirectory=build
+ mv debian/tmp/usr/bin/Witness_complex_strong_witness_persistence debian/tmp/usr/bin/gudhi-witness-complex-strong-witness-persistence
+ mv debian/tmp/usr/bin/Witness_complex_weak_witness_persistence debian/tmp/usr/bin/gudhi-witness-complex-weak-witness-persistence
+ mv debian/tmp/usr/bin/alpha_complex_3d_persistence debian/tmp/usr/bin/gudhi-alpha-complex-3d-persistence
+ mv debian/tmp/usr/bin/alpha_complex_persistence debian/tmp/usr/bin/gudhi-alpha-complex-persistence
+ mv debian/tmp/usr/bin/bottleneck_distance debian/tmp/usr/bin/gudhi-bottleneck-distance
+ mv debian/tmp/usr/bin/cubical_complex_persistence debian/tmp/usr/bin/gudhi-cubical-complex-persistence
+ mv debian/tmp/usr/bin/exact_alpha_complex_3d_persistence debian/tmp/usr/bin/gudhi-exact-alpha-complex-3d-persistence
+ mv debian/tmp/usr/bin/off_file_from_shape_generator debian/tmp/usr/bin/gudhi-off-file-from-shape-generator
+ mv debian/tmp/usr/bin/periodic_alpha_complex_3d_persistence debian/tmp/usr/bin/gudhi-periodic-alpha-complex-3d-persistence
+ mv debian/tmp/usr/bin/periodic_cubical_complex_persistence debian/tmp/usr/bin/gudhi-periodic-cubical-complex-persistence
+ mv debian/tmp/usr/bin/rips_distance_matrix_persistence debian/tmp/usr/bin/gudhi-rips-distance-matrix-persistence
+ mv debian/tmp/usr/bin/rips_persistence debian/tmp/usr/bin/gudhi-rips-persistence
+ mv debian/tmp/usr/bin/weighted_alpha_complex_3d_persistence debian/tmp/usr/bin/gudhi-weighted-alpha-complex-3d-persistence
+ mv debian/tmp/usr/bin/weighted_periodic_alpha_complex_3d_persistence debian/tmp/usr/bin/gudhi-weighted-periodic-alpha-complex-3d-persistence
+ install -D build/GudhUI/GudhUI debian/tmp/usr/bin/gudhui
override_dh_compress:
dh_compress -X.cpp