summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGard Spreemann <gspreemann@gmail.com>2018-06-12 15:23:04 +0200
committerGard Spreemann <gspreemann@gmail.com>2018-06-12 15:23:04 +0200
commitd13b585123c8be75b6256e4aba696dcd65fee388 (patch)
treee158be7df627ab0ffad3c0520d090e7f3b495138
parentb6d352a83740be5ce12e33b0b89980538246a504 (diff)
Patch to force linking against libatomic for parts that use TBB. Should fix building on MIPS et al.
-rw-r--r--debian/changelog4
-rw-r--r--debian/patches/0010-Force-linking-against-libatomic-for-parts-that-use-T.patch21
-rw-r--r--debian/patches/series1
3 files changed, 25 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index e75e09cb..d84a3a7d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,9 +1,11 @@
gudhi (2.1.0+dfsg-3) UNRELEASED; urgency=medium
* Add patch for floating point rounding problem on some architectures.
+ * Add patch that forces linking against libatomic. This hopefully fixes
+ building on MIPS et al.
* Install utilities (gudhi-utils).
- -- Gard Spreemann <gspreemann@gmail.com> Tue, 12 Jun 2018 10:50:01 +0200
+ -- Gard Spreemann <gspreemann@gmail.com> Tue, 12 Jun 2018 15:22:01 +0200
gudhi (2.1.0+dfsg-2) unstable; urgency=medium
diff --git a/debian/patches/0010-Force-linking-against-libatomic-for-parts-that-use-T.patch b/debian/patches/0010-Force-linking-against-libatomic-for-parts-that-use-T.patch
new file mode 100644
index 00000000..cbf39039
--- /dev/null
+++ b/debian/patches/0010-Force-linking-against-libatomic-for-parts-that-use-T.patch
@@ -0,0 +1,21 @@
+From: Gard Spreemann <gspreemann@gmail.com>
+Date: Tue, 12 Jun 2018 15:20:07 +0200
+Subject: Force linking against libatomic for parts that use TBB.
+
+---
+ cmake/modules/FindTBB.cmake | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/cmake/modules/FindTBB.cmake b/cmake/modules/FindTBB.cmake
+index 13f4d92..6baa8d7 100644
+--- a/cmake/modules/FindTBB.cmake
++++ b/cmake/modules/FindTBB.cmake
+@@ -375,6 +375,8 @@ if (TBB_INCLUDE_DIR)
+ endif(NOT TBB_without_pthread)
+ endif(UNIX AND NOT APPLE)
+
++ list(APPEND ALL_TBB_LIBRARIES atomic)
++
+ set (TBB_LIBRARIES ${ALL_TBB_LIBRARIES}
+ CACHE PATH "TBB libraries" FORCE)
+
diff --git a/debian/patches/series b/debian/patches/series
index 2a37f5ef..d1e36399 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -7,3 +7,4 @@ no-external-doc-resources.patch
0007-CGAL-4.12-compatibility.patch
0008-Force-linking-of-Python-module-with-CGAL.patch
0009-Rounding-workaround-on-i686.patch
+0010-Force-linking-against-libatomic-for-parts-that-use-T.patch