summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGard Spreemann <gspreemann@gmail.com>2018-06-15 14:09:05 +0200
committerGard Spreemann <gspreemann@gmail.com>2018-06-15 14:09:05 +0200
commitd5c8efb97594adc71912ef07900b8427d3973840 (patch)
tree023ae8811adea3c3427a6b42ec78b7f467175927
parentdfb9e96d8ad38add77e2c874cbe7c5d939cbf557 (diff)
Update patch.
-rw-r--r--debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch18
1 files changed, 10 insertions, 8 deletions
diff --git a/debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch b/debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch
index 3f5fb5bb..d58b56a9 100644
--- a/debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch
+++ b/debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch
@@ -6,8 +6,8 @@ Subject: Disable tests that use DFSG-deleted data files.
example/Nerve_GIC/CMakeLists.txt | 6 ------
example/Persistent_cohomology/CMakeLists.txt | 4 ----
example/Simplex_tree/CMakeLists.txt | 2 --
- utilities/Nerve_GIC/CMakeLists.txt | 6 ------
- 4 files changed, 18 deletions(-)
+ utilities/Nerve_GIC/CMakeLists.txt | 8 --------
+ 4 files changed, 20 deletions(-)
diff --git a/example/Nerve_GIC/CMakeLists.txt b/example/Nerve_GIC/CMakeLists.txt
index fdecf86..f63e08e 100644
@@ -59,19 +59,21 @@ index 857e851..48bb069 100644
install(TARGETS Simplex_tree_example_alpha_shapes_3_from_off DESTINATION bin)
diff --git a/utilities/Nerve_GIC/CMakeLists.txt b/utilities/Nerve_GIC/CMakeLists.txt
-index 215f9df..266171d 100644
+index 215f9df..20aeb8e 100644
--- a/utilities/Nerve_GIC/CMakeLists.txt
+++ b/utilities/Nerve_GIC/CMakeLists.txt
-@@ -14,12 +14,6 @@ if (NOT CGAL_VERSION VERSION_LESS 4.8.1)
- # Copy files for not to pollute sources when testing
- file(COPY "${CMAKE_SOURCE_DIR}/data/points/human.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+@@ -11,14 +11,6 @@ if (NOT CGAL_VERSION VERSION_LESS 4.8.1)
+ endif()
+ file(COPY KeplerMapperVisuFromTxtFile.py km.py DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- # Copy files for not to pollute sources when testing
+- file(COPY "${CMAKE_SOURCE_DIR}/data/points/human.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+-
- add_test(NAME Nerve_GIC_utilities_nerve COMMAND $<TARGET_FILE:Nerve>
- "human.off" "2" "10" "0.3")
-
- add_test(NAME Nerve_GIC_utilities_VoronoiGIC COMMAND $<TARGET_FILE:VoronoiGIC>
- "human.off" "100")
--
+
install(TARGETS Nerve DESTINATION bin)
install(TARGETS VoronoiGIC DESTINATION bin)
- install(FILES KeplerMapperVisuFromTxtFile.py km.py km.py.COPYRIGHT DESTINATION bin)