summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2020-12-10 09:52:17 +0100
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2020-12-10 09:52:17 +0100
commited7dcbebad7dd6fee114723eb34601b292a2e72c (patch)
tree2360e6fe94a390db8d50236f52c888bea02b7e25
parentcbb0e9feb0fa53239ed0cab41425ac4ce7fde0dd (diff)
Build python 3.9 pip package and use python 3.9 as default test package
-rw-r--r--.github/workflows/pip-build-linux.yml10
-rw-r--r--.github/workflows/pip-build-osx.yml2
-rw-r--r--.github/workflows/pip-build-windows.yml2
-rw-r--r--.github/workflows/pip-packaging-linux.yml17
-rw-r--r--.github/workflows/pip-packaging-osx.yml2
-rw-r--r--.github/workflows/pip-packaging-windows.yml2
6 files changed, 22 insertions, 13 deletions
diff --git a/.github/workflows/pip-build-linux.yml b/.github/workflows/pip-build-linux.yml
index 14fdc8d2..cf8ddadf 100644
--- a/.github/workflows/pip-build-linux.yml
+++ b/.github/workflows/pip-build-linux.yml
@@ -11,11 +11,11 @@ jobs:
- uses: actions/checkout@v1
with:
submodules: true
- - name: Build wheels for Python 3.8
+ - name: Build wheels for Python 3.9
run: |
- mkdir build_38
- cd build_38
- cmake -DCMAKE_BUILD_TYPE=Release -DPYTHON_EXECUTABLE=$PYTHON38/bin/python ..
+ mkdir build_39
+ cd build_39
+ cmake -DCMAKE_BUILD_TYPE=Release -DPYTHON_EXECUTABLE=$PYTHON39/bin/python ..
cd src/python
- $PYTHON38/bin/python setup.py bdist_wheel
+ $PYTHON39/bin/python setup.py bdist_wheel
auditwheel repair dist/*.whl \ No newline at end of file
diff --git a/.github/workflows/pip-build-osx.yml b/.github/workflows/pip-build-osx.yml
index 15b8880a..50b8b09c 100644
--- a/.github/workflows/pip-build-osx.yml
+++ b/.github/workflows/pip-build-osx.yml
@@ -8,7 +8,7 @@ jobs:
strategy:
max-parallel: 4
matrix:
- python-version: ['3.8']
+ python-version: ['3.9']
name: Build wheels for Python ${{ matrix.python-version }}
steps:
- uses: actions/checkout@v1
diff --git a/.github/workflows/pip-build-windows.yml b/.github/workflows/pip-build-windows.yml
index 995d52dd..aacbbc52 100644
--- a/.github/workflows/pip-build-windows.yml
+++ b/.github/workflows/pip-build-windows.yml
@@ -8,7 +8,7 @@ jobs:
strategy:
max-parallel: 4
matrix:
- python-version: ['3.8']
+ python-version: ['3.9']
name: Build wheels for Python ${{ matrix.python-version }}
steps:
- uses: actions/checkout@v1
diff --git a/.github/workflows/pip-packaging-linux.yml b/.github/workflows/pip-packaging-linux.yml
index bd524af9..469c3b3b 100644
--- a/.github/workflows/pip-packaging-linux.yml
+++ b/.github/workflows/pip-packaging-linux.yml
@@ -45,12 +45,21 @@ jobs:
cd src/python
$PYTHON38/bin/python setup.py bdist_wheel
auditwheel repair dist/*.whl
+ - name: Build wheels for Python 3.9
+ run: |
+ mkdir build_39
+ cd build_39
+ cmake -DCMAKE_BUILD_TYPE=Release -DPYTHON_EXECUTABLE=$PYTHON39/bin/python ..
+ cd src/python
+ $PYTHON39/bin/python setup.py bdist_wheel
+ auditwheel repair dist/*.whl
- name: Publish on PyPi
env:
TWINE_USERNAME: __token__
TWINE_PASSWORD: ${{ secrets.PYPI_PASSWORD }}
run: |
- $PYTHON38/bin/python -m twine upload build_35/src/python/wheelhouse/*
- $PYTHON38/bin/python -m twine upload build_36/src/python/wheelhouse/*
- $PYTHON38/bin/python -m twine upload build_37/src/python/wheelhouse/*
- $PYTHON38/bin/python -m twine upload build_38/src/python/wheelhouse/* \ No newline at end of file
+ $PYTHON39/bin/python -m twine upload build_35/src/python/wheelhouse/*
+ $PYTHON39/bin/python -m twine upload build_36/src/python/wheelhouse/*
+ $PYTHON39/bin/python -m twine upload build_37/src/python/wheelhouse/*
+ $PYTHON39/bin/python -m twine upload build_38/src/python/wheelhouse/*
+ $PYTHON39/bin/python -m twine upload build_39/src/python/wheelhouse/* \ No newline at end of file
diff --git a/.github/workflows/pip-packaging-osx.yml b/.github/workflows/pip-packaging-osx.yml
index c94369ac..46441e65 100644
--- a/.github/workflows/pip-packaging-osx.yml
+++ b/.github/workflows/pip-packaging-osx.yml
@@ -10,7 +10,7 @@ jobs:
strategy:
max-parallel: 4
matrix:
- python-version: ['3.5', '3.6', '3.7', '3.8']
+ python-version: ['3.5', '3.6', '3.7', '3.8', '3.9']
name: Build wheels for Python ${{ matrix.python-version }}
steps:
- uses: actions/checkout@v1
diff --git a/.github/workflows/pip-packaging-windows.yml b/.github/workflows/pip-packaging-windows.yml
index 8f4ab6e7..3a751486 100644
--- a/.github/workflows/pip-packaging-windows.yml
+++ b/.github/workflows/pip-packaging-windows.yml
@@ -10,7 +10,7 @@ jobs:
strategy:
max-parallel: 4
matrix:
- python-version: ['3.5', '3.6', '3.7', '3.8']
+ python-version: ['3.5', '3.6', '3.7', '3.8', '3.9']
name: Build wheels for Python ${{ matrix.python-version }}
steps:
- uses: actions/checkout@v1