summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVincent Rouvreau <vincent.rouvreau@inria.fr>2022-06-30 11:30:12 +0200
committerVincent Rouvreau <vincent.rouvreau@inria.fr>2022-06-30 11:30:12 +0200
commit17f68bb5be7a68fab17510740d2bdc28b70decea (patch)
treec0cef2eb456f8b6d32f0967561ca96c5b0c8bf0a
parente31556d04e4a957dd38b3e52e91e1a6cedd47f65 (diff)
code review: rename option WITH_GUDHI_THIRD_PARTY
-rw-r--r--.circleci/config.yml8
-rw-r--r--.github/for_maintainers/tests_strategy.md5
-rw-r--r--CMakeLists.txt4
-rw-r--r--src/CMakeLists.txt4
-rw-r--r--src/cmake/modules/GUDHI_options.cmake4
-rw-r--r--src/common/doc/installation.h4
6 files changed, 17 insertions, 12 deletions
diff --git a/.circleci/config.yml b/.circleci/config.yml
index 64e7fbb1..82ad19db 100644
--- a/.circleci/config.yml
+++ b/.circleci/config.yml
@@ -58,7 +58,7 @@ jobs:
git submodule update
mkdir build
cd build
- cmake -DWITH_GUDHI_CPP_DOCUMENTATION_ONLY=ON -DUSER_VERSION_DIR=version ..
+ cmake -DWITH_GUDHI_THIRD_PARTY=OFF -DUSER_VERSION_DIR=version ..
make user_version
cd version
cmake -DCMAKE_BUILD_TYPE=Release -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=ON -DPython_ADDITIONAL_VERSIONS=3 .
@@ -89,13 +89,13 @@ jobs:
git submodule update
mkdir build
cd build
- cmake -DWITH_GUDHI_CPP_DOCUMENTATION_ONLY=ON -DUSER_VERSION_DIR=version ..
+ cmake -DWITH_GUDHI_THIRD_PARTY=OFF -DUSER_VERSION_DIR=version ..
make user_version
cd version
mkdir build
cd build
- cmake -DWITH_GUDHI_CPP_DOCUMENTATION_ONLY=ON ..
- make doxygen 2>&1
+ cmake -DWITH_GUDHI_THIRD_PARTY=OFF ..
+ make doxygen
grep warning doxygen.log
cp doxygen.log html/
cp -R html /tmp/doxygen
diff --git a/.github/for_maintainers/tests_strategy.md b/.github/for_maintainers/tests_strategy.md
index c25acf9b..01248d3a 100644
--- a/.github/for_maintainers/tests_strategy.md
+++ b/.github/for_maintainers/tests_strategy.md
@@ -4,6 +4,11 @@ This document tries to sum up the tests strategy that has been put in place for
The aim is to help maintainers to anticipate third parties modifications, updates.
+## CMake options
+
+[CMake GUDHI options](../../src/cmake/modules/GUDHI_options.cmake) allows to activate/deactivate what should be built and tested.
+Note the special option `WITH_GUDHI_THIRD_PARTY` that, when set to `OFF`, accelerates doxygen documentation generation or `user_version` for instance.
+
## Builds
### Linux
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1164eaab..6c233459 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,7 +15,7 @@ set(GUDHI_PYTHON_PATH "src/python")
include(GUDHI_submodules)
-if (NOT WITH_GUDHI_CPP_DOCUMENTATION_ONLY)
+if (WITH_GUDHI_THIRD_PARTY)
# For third parties libraries management - To be done last as CGAL updates CMAKE_MODULE_PATH
include(GUDHI_third_party_libraries NO_POLICY_SCOPE)
endif()
@@ -56,7 +56,7 @@ foreach(GUDHI_MODULE ${GUDHI_MODULES})
endforeach()
endforeach()
-if (NOT WITH_GUDHI_CPP_DOCUMENTATION_ONLY)
+if (WITH_GUDHI_THIRD_PARTY)
add_subdirectory(src/GudhUI)
endif()
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index d2f12e5f..f9f77ef7 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -14,7 +14,7 @@ set(GUDHI_PYTHON_PATH "python")
include(GUDHI_submodules)
-if (NOT WITH_GUDHI_CPP_DOCUMENTATION_ONLY)
+if (WITH_GUDHI_THIRD_PARTY)
# For third parties libraries management - To be done last as CGAL updates CMAKE_MODULE_PATH
include(GUDHI_third_party_libraries NO_POLICY_SCOPE)
endif()
@@ -71,7 +71,7 @@ foreach(GUDHI_MODULE ${GUDHI_MODULES})
endforeach()
endforeach()
-if (NOT WITH_GUDHI_CPP_DOCUMENTATION_ONLY)
+if (WITH_GUDHI_THIRD_PARTY)
add_subdirectory(GudhUI)
endif()
diff --git a/src/cmake/modules/GUDHI_options.cmake b/src/cmake/modules/GUDHI_options.cmake
index 6655d605..fe328169 100644
--- a/src/cmake/modules/GUDHI_options.cmake
+++ b/src/cmake/modules/GUDHI_options.cmake
@@ -3,9 +3,9 @@ option(WITH_GUDHI_EXAMPLE "Activate/deactivate examples compilation and installa
option(WITH_GUDHI_PYTHON "Activate/deactivate python module compilation and installation" ON)
option(WITH_GUDHI_TEST "Activate/deactivate examples compilation and installation" ON)
option(WITH_GUDHI_UTILITIES "Activate/deactivate utilities compilation and installation" ON)
-option(WITH_GUDHI_CPP_DOCUMENTATION_ONLY "Build only the GUDHI C++ documentation (with doxygen)." OFF)
+option(WITH_GUDHI_THIRD_PARTY "Activate/deactivate third party libraries cmake detection. When set to OFF, it is usefull for doxygen or user_version i.e." ON)
-if (WITH_GUDHI_CPP_DOCUMENTATION_ONLY)
+if (NOT WITH_GUDHI_THIRD_PARTY)
set (WITH_GUDHI_BENCHMARK OFF)
set (WITH_GUDHI_EXAMPLE OFF)
set (WITH_GUDHI_PYTHON OFF)
diff --git a/src/common/doc/installation.h b/src/common/doc/installation.h
index b97142b6..c17855b6 100644
--- a/src/common/doc/installation.h
+++ b/src/common/doc/installation.h
@@ -43,13 +43,13 @@ make \endverbatim
*
* \subsection documentationgeneration C++ documentation
* To generate the C++ documentation, the <a target="_blank" href="http://www.doxygen.org/">doxygen</a> program
- * is required. Run the following command in a terminal:
+ * is required (version &ge; 1.9.3 is advised). Run the following command in a terminal:
* \verbatim make doxygen \endverbatim
* Documentation will be generated in a folder named <code>html</code>.
*
* In case there is not a full setup present and only the documentation should be build the following command sequence
* can be used:
-\verbatim cmake -DWITH_GUDHI_CPP_DOCUMENTATION_ONLY=ON ..
+\verbatim cmake -DWITH_GUDHI_THIRD_PARTY=OFF ..
make doxygen\endverbatim
*
* \subsection helloworld Hello world !