summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2021-04-22 09:28:45 +0200
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2021-04-22 09:28:45 +0200
commit1d7011f32573bb617894a3f263e2537c1f3a8649 (patch)
tree4212dd10350b21e072a10ffd83b7e0da09daf576
parentaf94bf9de8a4c08fe4d9a0c8719ae696b501169f (diff)
Add examples in doc and removes TBB link as not required by coxeter
-rw-r--r--src/Coxeter_triangulation/example/CMakeLists.txt9
-rw-r--r--src/Coxeter_triangulation/test/CMakeLists.txt3
-rw-r--r--src/common/doc/examples.h3
-rw-r--r--src/common/doc/installation.h8
4 files changed, 11 insertions, 12 deletions
diff --git a/src/Coxeter_triangulation/example/CMakeLists.txt b/src/Coxeter_triangulation/example/CMakeLists.txt
index 840e24e4..7f81c599 100644
--- a/src/Coxeter_triangulation/example/CMakeLists.txt
+++ b/src/Coxeter_triangulation/example/CMakeLists.txt
@@ -5,24 +5,15 @@ if (NOT EIGEN3_VERSION VERSION_LESS 3.1.0)
if (NOT CGAL_VERSION VERSION_LESS 4.11.0)
add_executable ( Coxeter_triangulation_manifold_tracing_flat_torus_with_boundary_example manifold_tracing_flat_torus_with_boundary.cpp )
target_link_libraries(Coxeter_triangulation_manifold_tracing_flat_torus_with_boundary_example ${CGAL_LIBRARY})
- if (TBB_FOUND)
- target_link_libraries(Coxeter_triangulation_manifold_tracing_flat_torus_with_boundary_example ${TBB_LIBRARIES})
- endif()
add_test(NAME Coxeter_triangulation_manifold_tracing_flat_torus_with_boundary_example
COMMAND $<TARGET_FILE:Coxeter_triangulation_manifold_tracing_flat_torus_with_boundary_example>)
endif()
add_executable ( Coxeter_triangulation_manifold_tracing_custom_function_example manifold_tracing_custom_function.cpp )
- if (TBB_FOUND)
- target_link_libraries(Coxeter_triangulation_manifold_tracing_custom_function_example ${TBB_LIBRARIES})
- endif()
add_test(NAME Coxeter_triangulation_manifold_tracing_custom_function_example
COMMAND $<TARGET_FILE:Coxeter_triangulation_manifold_tracing_custom_function_example>)
add_executable ( Coxeter_triangulation_cell_complex_from_basic_circle_manifold_example cell_complex_from_basic_circle_manifold.cpp )
- if (TBB_FOUND)
- target_link_libraries(Coxeter_triangulation_cell_complex_from_basic_circle_manifold_example ${TBB_LIBRARIES})
- endif()
add_test(NAME Coxeter_triangulation_cell_complex_from_basic_circle_manifold_example
COMMAND $<TARGET_FILE:Coxeter_triangulation_cell_complex_from_basic_circle_manifold_example>)
endif() \ No newline at end of file
diff --git a/src/Coxeter_triangulation/test/CMakeLists.txt b/src/Coxeter_triangulation/test/CMakeLists.txt
index 3da2410f..74ded91e 100644
--- a/src/Coxeter_triangulation/test/CMakeLists.txt
+++ b/src/Coxeter_triangulation/test/CMakeLists.txt
@@ -26,8 +26,5 @@ if (NOT EIGEN3_VERSION VERSION_LESS 3.1.0)
gudhi_add_boost_test(Coxeter_triangulation_manifold_tracing_test)
add_executable ( Coxeter_triangulation_cell_complex_test cell_complex_test.cpp )
- if (TBB_FOUND)
- target_link_libraries(Coxeter_triangulation_cell_complex_test ${TBB_LIBRARIES})
- endif()
gudhi_add_boost_test(Coxeter_triangulation_cell_complex_test)
endif() \ No newline at end of file
diff --git a/src/common/doc/examples.h b/src/common/doc/examples.h
index 474f8699..a8548f6a 100644
--- a/src/common/doc/examples.h
+++ b/src/common/doc/examples.h
@@ -92,5 +92,8 @@
* @example Persistence_representations/persistence_landscapes/create_landscapes.cpp
* @example Persistence_representations/persistence_landscapes/compute_distance_of_landscapes.cpp
* @example Persistence_representations/persistence_landscapes/plot_landscapes.cpp
+ * @example Coxeter_triangulation/cell_complex_from_basic_circle_manifold.cpp
+ * @example Coxeter_triangulation/manifold_tracing_custom_function.cpp
+ * @example Coxeter_triangulation/manifold_tracing_flat_torus_with_boundary.cpp
*/
diff --git a/src/common/doc/installation.h b/src/common/doc/installation.h
index c2e63a24..c0e36a59 100644
--- a/src/common/doc/installation.h
+++ b/src/common/doc/installation.h
@@ -125,6 +125,8 @@ make doxygen
* Alpha_complex/Weighted_alpha_complex_3d_from_points.cpp</a>
* \li <a href="_alpha_complex_2alpha_complex_3d_persistence_8cpp-example.html">
* Alpha_complex/alpha_complex_3d_persistence.cpp</a>
+ * \li <a href="_coxeter_triangulation_2manifold_tracing_flat_torus_with_boundary_8cpp-example.html">
+ * Coxeter_triangulation/manifold_tracing_flat_torus_with_boundary.cpp</a>
*
* \subsection eigen Eigen
* Some GUDHI modules (cf. \ref main_page "modules list"), and few examples require
@@ -169,6 +171,12 @@ make doxygen
* Witness_complex/example_witness_complex_off.cpp</a>
* \li <a href="_witness_complex_2example_witness_complex_sphere_8cpp-example.html">
* Witness_complex/example_witness_complex_sphere.cpp</a>
+ * \li <a href="_coxeter_triangulation_2cell_complex_from_basic_circle_manifold_8cpp-example.html">
+ * Coxeter_triangulation/cell_complex_from_basic_circle_manifold.cpp</a>
+ * \li <a href="_coxeter_triangulation_2manifold_tracing_custom_function_8cpp-example.html">
+ * Coxeter_triangulation/manifold_tracing_custom_function.cpp</a>
+ * \li <a href="_coxeter_triangulation_2manifold_tracing_flat_torus_with_boundary_8cpp-example.html">
+ * Coxeter_triangulation/manifold_tracing_flat_torus_with_boundary.cpp</a>
*
* \subsection tbb Threading Building Blocks
* <a target="_blank" href="https://www.threadingbuildingblocks.org/">Intel&reg; TBB</a> lets you easily write parallel