summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVincent Rouvreau <vincent.rouvreau@inria.fr>2022-06-13 16:40:09 +0200
committerVincent Rouvreau <vincent.rouvreau@inria.fr>2022-06-13 16:40:09 +0200
commit4f4fef6c14afa8371d9273b7161c78213bfcd6f6 (patch)
treeadd84598cf9ca38852adfa3b23d5e834f9910e64
parent610ed41d9465f3b8fc56535368b467e217399ac1 (diff)
Move new option in the correct file. Disable every option when only build cpp documentation
-rw-r--r--CMakeLists.txt3
-rw-r--r--src/cmake/modules/GUDHI_options.cmake9
2 files changed, 9 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 47d87cd1..f946e111 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,3 @@
-
-option(WITH_GUDHI_CPP_DOCUMENTATION_ONLY "Build only the GUDHI C++ documentation (with doxygen)." OFF)
-
cmake_minimum_required(VERSION 3.5)
project(GUDHIdev)
diff --git a/src/cmake/modules/GUDHI_options.cmake b/src/cmake/modules/GUDHI_options.cmake
index bffb3ffc..6655d605 100644
--- a/src/cmake/modules/GUDHI_options.cmake
+++ b/src/cmake/modules/GUDHI_options.cmake
@@ -3,3 +3,12 @@ option(WITH_GUDHI_EXAMPLE "Activate/deactivate examples compilation and installa
option(WITH_GUDHI_PYTHON "Activate/deactivate python module compilation and installation" ON)
option(WITH_GUDHI_TEST "Activate/deactivate examples compilation and installation" ON)
option(WITH_GUDHI_UTILITIES "Activate/deactivate utilities compilation and installation" ON)
+option(WITH_GUDHI_CPP_DOCUMENTATION_ONLY "Build only the GUDHI C++ documentation (with doxygen)." OFF)
+
+if (WITH_GUDHI_CPP_DOCUMENTATION_ONLY)
+ set (WITH_GUDHI_BENCHMARK OFF)
+ set (WITH_GUDHI_EXAMPLE OFF)
+ set (WITH_GUDHI_PYTHON OFF)
+ set (WITH_GUDHI_TEST OFF)
+ set (WITH_GUDHI_UTILITIES OFF)
+endif() \ No newline at end of file