summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHind-M <hind.montassif@gmail.com>2021-10-25 15:34:03 +0200
committerHind-M <hind.montassif@gmail.com>2021-10-25 15:34:03 +0200
commit5db7ab2b55262a88c0ceecbb9c7ea004d9ed087e (patch)
tree7090f11f28261d5b733eb70f7b9657298144b8dd
parentc9d6439fb9a6e65d7aa9f18bce675de65e901a0d (diff)
Enable WITH_GUDHI_REMOTE_TEST option for python target in CI platforms
-rw-r--r--.appveyor.yml11
-rw-r--r--.circleci/config.yml20
-rw-r--r--.github/for_maintainers/tests_strategy.md12
-rw-r--r--azure-pipelines.yml2
-rw-r--r--src/cmake/modules/GUDHI_modules.cmake6
5 files changed, 14 insertions, 37 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index ee6067e0..e90f1b83 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -27,10 +27,7 @@ environment:
CMAKE_FLAGS: -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_TEST=OFF -DWITH_GUDHI_UTILITIES=ON -DWITH_GUDHI_PYTHON=OFF
- target: Python
- CMAKE_FLAGS: -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_TEST=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=ON
-
- - target: PythonTestsWithNetwork
- CMAKE_FLAGS: -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_TEST=ON -DWITH_GUDHI_REMOTE_TEST=ON -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=ON
+ CMAKE_FLAGS: -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_TEST=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=ON -DWITH_GUDHI_REMOTE_TEST=ON
cache:
@@ -59,12 +56,12 @@ build_script:
- mkdir build
- cd build
- cmake -G "Visual Studio 15 2017 Win64" %CMAKE_FLAGS% %CMAKE_GMP_FLAGS% %CMAKE_MPFR_FLAGS% %CMAKE_VCPKG_FLAGS% ..
- - if or ([%target%]==[Python]) ([%target%]==[PythonTestsWithNetwork]) {
+ - if [%target%]==[Python] (
cd src/python &
type setup.py &
MSBuild Cython.sln /m /p:Configuration=Release /p:Platform=x64 &
ctest -j 1 --output-on-failure -C Release
- } else {
+ ) else (
MSBuild GUDHIdev.sln /m /p:Configuration=Release /p:Platform=x64 &
ctest -j 1 --output-on-failure -C Release -E diff_files
- }
+ )
diff --git a/.circleci/config.yml b/.circleci/config.yml
index 262e124b..90737006 100644
--- a/.circleci/config.yml
+++ b/.circleci/config.yml
@@ -61,7 +61,7 @@ jobs:
cmake -DUSER_VERSION_DIR=version ..
make user_version
cd version
- cmake -DCMAKE_BUILD_TYPE=Release -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=ON -DPython_ADDITIONAL_VERSIONS=3 .
+ cmake -DCMAKE_BUILD_TYPE=Release -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=ON -DPython_ADDITIONAL_VERSIONS=3 -DWITH_GUDHI_REMOTE_TEST=ON .
cd python
python3 setup.py build_ext --inplace
make sphinx
@@ -77,23 +77,6 @@ jobs:
path: /tmp/htmlcov
destination: htmlcov
- python_tests_with_network:
- docker:
- - image: gudhi/ci_for_gudhi:latest
- steps:
- - checkout
- - run:
- name: Build and test python module with network
- command: |
- git submodule init
- git submodule update
- mkdir build
- cd build
- cmake -DCMAKE_BUILD_TYPE=Release -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=ON -DPython_ADDITIONAL_VERSIONS=3 -DWITH_GUDHI_TEST=ON -DWITH_GUDHI_REMOTE_TEST=ON ..
- cd src/python
- python3 setup.py build_ext --inplace
- ctest --output-on-failure
-
doxygen:
docker:
- image: gudhi/ci_for_gudhi:latest
@@ -262,5 +245,4 @@ workflows:
- tests
- utils
- python
- - python_tests_with_network
- doxygen
diff --git a/.github/for_maintainers/tests_strategy.md b/.github/for_maintainers/tests_strategy.md
index 610e1749..2bba3f42 100644
--- a/.github/for_maintainers/tests_strategy.md
+++ b/.github/for_maintainers/tests_strategy.md
@@ -14,8 +14,7 @@ As all the third parties are already installed (thanks to docker), the compilati
* tests (C++)
* utils (C++)
* doxygen (C++ documentation that is available in the artefacts)
-* python (including documentation and code coverage that are available in the artefacts)
-* python_tests_with_network (includes previous python with WITH_GUDHI_REMOTE_TEST option enabled which adds datasets fetching test)
+* python (including documentation and code coverage that are available in the artefacts; here the WITH_GUDHI_REMOTE_TEST option is enabled which adds datasets fetching test)
(cf. `.circleci/config.yml`)
@@ -40,13 +39,12 @@ docker push gudhi/ci_for_gudhi_wo_cgal:latest
### Windows
-The compilations has been seperated by categories to be parallelized, but I don't know why builds are not run in parallel:
+The compilations has been separated by categories to be parallelized, but I don't know why builds are not run in parallel:
* examples (C++)
* tests (C++)
* utils (C++)
-* python
-* python tests with network
+* python (here the WITH_GUDHI_REMOTE_TEST option is enabled which adds datasets fetching test)
Doxygen (C++) is not tested.
(cf. `.appveyor.yml`)
@@ -56,12 +54,12 @@ In case of installation issue, check in [vcpkg issues](https://github.com/micros
### OSx
-The compilations has been seperated by categories to be parallelized:
+The compilations has been separated by categories to be parallelized:
* examples (C++)
* tests (C++)
* utils (C++)
-* python
+* python (here the WITH_GUDHI_REMOTE_TEST option is enabled which adds datasets fetching test)
* Doxygen (C++)
(cf. `azure-pipelines.yml`)
diff --git a/azure-pipelines.yml b/azure-pipelines.yml
index 6c194f2a..6e102b83 100644
--- a/azure-pipelines.yml
+++ b/azure-pipelines.yml
@@ -30,7 +30,7 @@ jobs:
source activate gudhi_build_env
mkdir build
cd build
- cmake -DCMAKE_BUILD_TYPE:STRING=$(cmakeBuildType) -DWITH_GUDHI_TEST=ON -DWITH_GUDHI_UTILITIES=ON -DWITH_GUDHI_PYTHON=ON -DPython_ADDITIONAL_VERSIONS=3 ..
+ cmake -DCMAKE_BUILD_TYPE:STRING=$(cmakeBuildType) -DWITH_GUDHI_TEST=ON -DWITH_GUDHI_UTILITIES=ON -DWITH_GUDHI_PYTHON=ON -DPython_ADDITIONAL_VERSIONS=3 -DWITH_GUDHI_REMOTE_TEST=ON ..
make -j 4
make doxygen
ctest -j 4 --output-on-failure # -E sphinx remove sphinx build as it fails
diff --git a/src/cmake/modules/GUDHI_modules.cmake b/src/cmake/modules/GUDHI_modules.cmake
index 7cdce307..cbed6351 100644
--- a/src/cmake/modules/GUDHI_modules.cmake
+++ b/src/cmake/modules/GUDHI_modules.cmake
@@ -18,11 +18,11 @@ function(add_gudhi_module file_path)
endfunction(add_gudhi_module)
option(WITH_GUDHI_BENCHMARK "Activate/deactivate benchmark compilation" OFF)
-option(WITH_GUDHI_EXAMPLE "Activate/deactivate examples compilation and installation" OFF)
+option(WITH_GUDHI_EXAMPLE "Activate/deactivate examples compilation" OFF)
option(WITH_GUDHI_REMOTE_TEST "Activate/deactivate datasets fetching test which uses the Internet" OFF)
option(WITH_GUDHI_PYTHON "Activate/deactivate python module compilation and installation" ON)
-option(WITH_GUDHI_TEST "Activate/deactivate examples compilation and installation" ON)
-option(WITH_GUDHI_UTILITIES "Activate/deactivate utilities compilation and installation" ON)
+option(WITH_GUDHI_TEST "Activate/deactivate tests compilation" ON)
+option(WITH_GUDHI_UTILITIES "Activate/deactivate utilities compilation" ON)
if (WITH_GUDHI_BENCHMARK)
set(GUDHI_SUB_DIRECTORIES "${GUDHI_SUB_DIRECTORIES};benchmark")