summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVincent Rouvreau <vincent.rouvreau@inria.fr>2021-12-17 13:57:45 +0100
committerVincent Rouvreau <vincent.rouvreau@inria.fr>2021-12-17 13:57:45 +0100
commit5eb591bee0cae488af7e5b49f94d0f1c02840fd3 (patch)
tree6f52938e9ac2c9ec6dc703f2ed734fea6a1b1547
parentb9a7226a7bac01eb10651851363b87b4d60d84c6 (diff)
Make it more powershellable
-rw-r--r--.github/workflows/pip-build-windows.yml26
1 files changed, 12 insertions, 14 deletions
diff --git a/.github/workflows/pip-build-windows.yml b/.github/workflows/pip-build-windows.yml
index 2bbc6f49..f1829e70 100644
--- a/.github/workflows/pip-build-windows.yml
+++ b/.github/workflows/pip-build-windows.yml
@@ -23,31 +23,29 @@ jobs:
set VCPKG_BUILD_TYPE=release
vcpkg install eigen3 cgal --triplet x64-windows
vcpkg version
- ls C:/vcpkg/installed/x64-windows/bin
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_TOOLCHAIN_FILE=c:/vcpkg/scripts/buildsystems/vcpkg.cmake -DVCPKG_TARGET_TRIPLET=x64-windows .
- cd ${{ github.workspace }}
- python -m pip install --user -r ext/gudhi-deploy/build-requirements.txt
+ ls "C:\vcpkg\installed\x64-windows\bin\"
+ python -m pip install --user -r .\ext\gudhi-deploy\build-requirements.txt
python -m pip list
- name: Build python wheel
run: |
mkdir build
- cd build
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_TOOLCHAIN_FILE=c:/vcpkg/scripts/buildsystems/vcpkg.cmake -DVCPKG_TARGET_TRIPLET=x64-windows ..
- echo %CD%
+ cd ".\build\"
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_TOOLCHAIN_FILE=c:\Tools\vcpkg\scripts\buildsystems\vcpkg.cmake -DVCPKG_TARGET_TRIPLET=x64-windows ..
+ Get-Location
dir
- cd src\python
- cp c:/vcpkg/installed/x64-windows/bin/mpfr-6.dll gudhi/
- cp c:/vcpkg/installed/x64-windows/bin/gmp.dll gudhi/
+ cd ".\src\python\"
+ cp "C:\vcpkg\installed\x64-windows\bin\mpfr-6.dll" ".\gudhi\"
+ cp "C:\vcpkg\installed\x64-windows\bin\gmp.dll" ".\gudhi\"
python setup.py bdist_wheel
ls dist
- name: Install and test python wheel
run: |
- echo %CD%
+ Get-Location
dir
- cd dist
+ cd ".\dist\"
Get-ChildItem *.whl | ForEach-Object{python -m pip install --user $_.Name}
cd ..
- echo %CD%
+ Get-Location
dir
python -m pip install --user pytest
- python -m pytest src/python/test/test_alpha_complex.py
+ python -m pytest ".\src\python\test\test_alpha_complex.py"