summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHind-M <hind.montassif@gmail.com>2021-09-27 17:32:55 +0200
committerHind-M <hind.montassif@gmail.com>2021-09-27 17:32:55 +0200
commit613db2444a9a12a64b097b944d0180e4fdbff71f (patch)
treec38ee8d325a367ee8f05bc1d3ca7cf1a8b434a0b
parent8749199e00c0ed1c32b8e0198a65797de3ad192a (diff)
Document option WITH_NETWORK in installation manual and tests_strategy
Enable WITH_NETWORK option in some of the CI platforms (for a minimal testing)
-rw-r--r--.appveyor.yml5
-rw-r--r--.circleci/config.yml18
-rw-r--r--.github/for_maintainers/tests_strategy.md4
-rw-r--r--src/common/doc/installation.h2
4 files changed, 27 insertions, 2 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index 9ff8f157..b44e08e1 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -29,6 +29,9 @@ environment:
- target: Python
CMAKE_FLAGS: -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_TEST=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=ON
+ - target: PythonTestsWithNetwork
+ CMAKE_FLAGS: -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_TEST=ON -DWITH_NETWORK=ON -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=ON
+
cache:
- c:\Tools\vcpkg\installed
@@ -56,7 +59,7 @@ build_script:
- mkdir build
- cd build
- cmake -G "Visual Studio 15 2017 Win64" %CMAKE_FLAGS% %CMAKE_GMP_FLAGS% %CMAKE_MPFR_FLAGS% %CMAKE_VCPKG_FLAGS% ..
- - if [%target%]==[Python] (
+ - if [[%target%]==[Python] || [%target%]==[PythonTestsWithNetwork]] (
cd src/python &
type setup.py &
MSBuild Cython.sln /m /p:Configuration=Release /p:Platform=x64 &
diff --git a/.circleci/config.yml b/.circleci/config.yml
index f6a875dd..85e42f8a 100644
--- a/.circleci/config.yml
+++ b/.circleci/config.yml
@@ -77,6 +77,23 @@ jobs:
path: /tmp/htmlcov
destination: htmlcov
+ python_tests_with_network:
+ docker:
+ - image: gudhi/ci_for_gudhi:latest
+ steps:
+ - checkout
+ - run:
+ name: Build and test python module with network
+ command: |
+ git submodule init
+ git submodule update
+ mkdir build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=Release -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=ON -DPython_ADDITIONAL_VERSIONS=3 -DWITH_GUDHI_TEST=ON -DWITH_NETWORK=ON ..
+ cd src/python
+ python3 setup.py build_ext --inplace
+ ctest --output-on-failure
+
doxygen:
docker:
- image: gudhi/ci_for_gudhi:latest
@@ -245,4 +262,5 @@ workflows:
- tests
- utils
- python
+ - python_tests_with_network
- doxygen
diff --git a/.github/for_maintainers/tests_strategy.md b/.github/for_maintainers/tests_strategy.md
index 9c181740..8fd7ac0d 100644
--- a/.github/for_maintainers/tests_strategy.md
+++ b/.github/for_maintainers/tests_strategy.md
@@ -8,13 +8,14 @@ The aim is to help maintainers to anticipate third parties modifications, update
### Linux
-As all the third parties are already installed (thanks to docker), the compilations has been seperated by categories to be parallelized:
+As all the third parties are already installed (thanks to docker), the compilations has been separated by categories to be parallelized:
* examples (C++)
* tests (C++)
* utils (C++)
* doxygen (C++ documentation that is available in the artefacts)
* python (including documentation and code coverage that are available in the artefacts)
+* python_tests_with_network (includes previous python with WITH_NETWORK option enabled which adds datasets fetching test)
(cf. `.circleci/config.yml`)
@@ -45,6 +46,7 @@ The compilations has been seperated by categories to be parallelized, but I don'
* tests (C++)
* utils (C++)
* python
+* python tests with network
Doxygen (C++) is not tested.
(cf. `.appveyor.yml`)
diff --git a/src/common/doc/installation.h b/src/common/doc/installation.h
index 610aa17e..72d4b1e5 100644
--- a/src/common/doc/installation.h
+++ b/src/common/doc/installation.h
@@ -40,6 +40,8 @@ make \endverbatim
* `make test` is using <a href="https://cmake.org/cmake/help/latest/manual/ctest.1.html">Ctest</a> (CMake test driver
* program). If some of the tests are failing, please send us the result of the following command:
* \verbatim ctest --output-on-failure \endverbatim
+ * Testing fetching datasets feature requires the use of the internet and is disabled by default. If you want to include this test, set WITH_NETWORK to ON when building in the previous step (note that this test is included in the python module):
+ * \verbatim cmake -DCMAKE_BUILD_TYPE=Release -DWITH_GUDHI_TEST=ON -DWITH_NETWORK=ON --DWITH_GUDHI_PYTHON=ON .. \endverbatim
*
* \subsection documentationgeneration Documentation
* To generate the documentation, <a target="_blank" href="http://www.doxygen.org/">Doxygen</a> is required.