summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2021-05-20 22:00:29 +0200
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2021-05-20 22:00:29 +0200
commit732aeb08b3c96ec66a33af85579c740fcb690ec0 (patch)
tree864f609a3624054acc429482dfc4bb58dbe11882
parentb8b7f4880ceae8d3a65502b86aae0538072253e8 (diff)
parent17a5cb224832c9645de023dc6ab588eccce8a6a1 (diff)
merge and resolve conflicts for upstream/fix_windows_pip_package_3.4.1
-rw-r--r--.github/workflows/pip-build-linux.yml10
-rw-r--r--.github/workflows/pip-build-osx.yml4
-rw-r--r--.github/workflows/pip-build-windows.yml30
-rw-r--r--.github/workflows/pip-packaging-linux.yml34
-rw-r--r--.github/workflows/pip-packaging-osx.yml4
-rw-r--r--.github/workflows/pip-packaging-windows.yml28
6 files changed, 89 insertions, 21 deletions
diff --git a/.github/workflows/pip-build-linux.yml b/.github/workflows/pip-build-linux.yml
index 726ed0d5..12979a86 100644
--- a/.github/workflows/pip-build-linux.yml
+++ b/.github/workflows/pip-build-linux.yml
@@ -4,7 +4,7 @@ on: [push, pull_request]
jobs:
build:
- name: build pip wheels
+ name: build pip wheel
runs-on: ubuntu-latest
# cf. https://github.com/GUDHI/gudhi-deploy/blob/main/Dockerfile_for_pip
container: gudhi/pip_for_gudhi
@@ -12,11 +12,15 @@ jobs:
- uses: actions/checkout@v1
with:
submodules: true
- - name: Build wheels for Python 3.9
+ - name: Build wheel for Python 3.9
run: |
mkdir build_39
cd build_39
cmake -DCMAKE_BUILD_TYPE=Release -DPYTHON_EXECUTABLE=$PYTHON39/bin/python ..
cd src/python
$PYTHON39/bin/python setup.py bdist_wheel
- auditwheel repair dist/*.whl \ No newline at end of file
+ auditwheel repair dist/*.whl
+ - name: Install and test wheel for Python 3.9
+ run: |
+ $PYTHON39/bin/python -m pip install --user pytest build_39/src/python/dist/*.whl
+ $PYTHON39/bin/python -m pytest src/python/test/test_alpha_complex.py
diff --git a/.github/workflows/pip-build-osx.yml b/.github/workflows/pip-build-osx.yml
index 732e26af..1626bb77 100644
--- a/.github/workflows/pip-build-osx.yml
+++ b/.github/workflows/pip-build-osx.yml
@@ -32,3 +32,7 @@ jobs:
cmake -DCMAKE_BUILD_TYPE=Release -DPython_ADDITIONAL_VERSIONS=3 ..
cd src/python
python setup.py bdist_wheel
+ - name: Install and test python wheel
+ run: |
+ python -m pip install --user pytest build/src/python/dist/*.whl
+ python -m pytest src/python/test/test_alpha_complex.py
diff --git a/.github/workflows/pip-build-windows.yml b/.github/workflows/pip-build-windows.yml
index d07e8c46..0080f4d5 100644
--- a/.github/workflows/pip-build-windows.yml
+++ b/.github/workflows/pip-build-windows.yml
@@ -20,18 +20,36 @@ jobs:
architecture: x64
- name: Install dependencies
run: |
- vcpkg update
- vcpkg upgrade --no-dry-run
- type c:/vcpkg/ports/cgal/portfile.cmake
- vcpkg install eigen3 cgal --triplet x64-windows
+ cd c:/vcpkg
+ git fetch --all --tags
+ git checkout 2020.11-1
+ bootstrap-vcpkg.bat
+ set VCPKG_BUILD_TYPE=release
+ vcpkg install eigen3 mpfr boost-accumulators boost-algorithm boost-bimap boost-callable-traits boost-concept-check boost-container boost-core boost-detail boost-filesystem boost-functional boost-fusion boost-geometry boost-graph boost-heap boost-intrusive boost-iostreams boost-iterator boost-lambda boost-logic boost-math boost-mpl boost-multi-index boost-multiprecision boost-numeric-conversion boost-optional boost-parameter boost-pool boost-preprocessor boost-property-map boost-property-tree boost-ptr-container boost-random boost-range boost-serialization boost-spirit boost-thread boost-tuple boost-type-traits boost-units boost-utility boost-variant --triplet x64-windows
+ vcpkg version
+ ls C:/vcpkg/installed/x64-windows/bin
+ Invoke-WebRequest https://github.com/CGAL/cgal/releases/download/v5.2.1/CGAL-5.2.1.zip -OutFile CGAL-5.2.1.zip
+ Expand-Archive -Path CGAL-5.2.1.zip -DestinationPath .
+ cd CGAL-5.2.1
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_TOOLCHAIN_FILE=c:/vcpkg/scripts/buildsystems/vcpkg.cmake -DVCPKG_TARGET_TRIPLET=x64-windows -DGMP_INCLUDE_DIR=c:/vcpkg/installed/x64-windows/include -DGMP_LIBRARIES=c:/vcpkg/installed/x64-windows/bin/mpir.dll .
+ cd ${{ github.workspace }}
python -m pip install --user -r ext/gudhi-deploy/build-requirements.txt
python -m pip list
- name: Build python wheel
run: |
mkdir build
cd build
- cmake -DCMAKE_BUILD_TYPE=Release -DGMP_INCLUDE_DIR="c:/vcpkg/installed/x64-windows/include" -DGMP_LIBRARIES="c:/vcpkg/installed/x64-windows/lib/mpir.lib" -DGMP_LIBRARIES_DIR="c:/vcpkg/installed/x64-windows/lib" -DCMAKE_TOOLCHAIN_FILE=C:/vcpkg/scripts/buildsystems/vcpkg.cmake -DVCPKG_TARGET_TRIPLET=x64-windows -DPython_ADDITIONAL_VERSIONS=3 ..
+ cmake -DCGAL_DIR=c:/vcpkg/CGAL-5.2.1 -DCMAKE_BUILD_TYPE=Release -DCMAKE_TOOLCHAIN_FILE=c:/vcpkg/scripts/buildsystems/vcpkg.cmake -DVCPKG_TARGET_TRIPLET=x64-windows -DGMP_INCLUDE_DIR=c:/vcpkg/installed/x64-windows/include -DGMP_LIBRARIES=c:/vcpkg/installed/x64-windows/bin/mpir.dll ..
cd src/python
cp c:/vcpkg/installed/x64-windows/bin/mpfr.dll gudhi/
cp c:/vcpkg/installed/x64-windows/bin/mpir.dll gudhi/
- python setup.py bdist_wheel \ No newline at end of file
+ python setup.py bdist_wheel
+ ls dist
+ - name: Install and test python wheel
+ run: |
+ cd ${{ github.workspace }}
+ cd build/src/python/dist/
+ Get-ChildItem *.whl | ForEach-Object{python -m pip install --user $_.Name}
+ cd ${{ github.workspace }}
+ python -m pip install --user pytest
+ python -m pytest src/python/test/test_alpha_complex.py
diff --git a/.github/workflows/pip-packaging-linux.yml b/.github/workflows/pip-packaging-linux.yml
index 95e8f034..0fa2c083 100644
--- a/.github/workflows/pip-packaging-linux.yml
+++ b/.github/workflows/pip-packaging-linux.yml
@@ -6,7 +6,7 @@ on:
jobs:
build:
- name: build pip wheels
+ name: build pip wheel
runs-on: ubuntu-latest
# cf. https://github.com/GUDHI/gudhi-deploy/blob/main/Dockerfile_for_pip
container: gudhi/pip_for_gudhi
@@ -14,7 +14,7 @@ jobs:
- uses: actions/checkout@v1
with:
submodules: true
- - name: Build wheels for Python 3.5
+ - name: Build wheel for Python 3.5
run: |
mkdir build_35
cd build_35
@@ -22,7 +22,11 @@ jobs:
cd src/python
$PYTHON35/bin/python setup.py bdist_wheel
auditwheel repair dist/*.whl
- - name: Build wheels for Python 3.6
+ - name: Install and test wheel for Python 3.5
+ run: |
+ $PYTHON35/bin/python -m pip install --user pytest build_35/src/python/dist/*.whl
+ $PYTHON35/bin/python -m pytest src/python/test/test_alpha_complex.py
+ - name: Build wheel for Python 3.6
run: |
mkdir build_36
cd build_36
@@ -30,7 +34,11 @@ jobs:
cd src/python
$PYTHON36/bin/python setup.py bdist_wheel
auditwheel repair dist/*.whl
- - name: Build wheels for Python 3.7
+ - name: Install and test wheel for Python 3.6
+ run: |
+ $PYTHON36/bin/python -m pip install --user pytest build_36/src/python/dist/*.whl
+ $PYTHON36/bin/python -m pytest src/python/test/test_alpha_complex.py
+ - name: Build wheel for Python 3.7
run: |
mkdir build_37
cd build_37
@@ -38,7 +46,11 @@ jobs:
cd src/python
$PYTHON37/bin/python setup.py bdist_wheel
auditwheel repair dist/*.whl
- - name: Build wheels for Python 3.8
+ - name: Install and test wheel for Python 3.7
+ run: |
+ $PYTHON37/bin/python -m pip install --user pytest build_37/src/python/dist/*.whl
+ $PYTHON37/bin/python -m pytest src/python/test/test_alpha_complex.py
+ - name: Build wheel for Python 3.8
run: |
mkdir build_38
cd build_38
@@ -46,7 +58,11 @@ jobs:
cd src/python
$PYTHON38/bin/python setup.py bdist_wheel
auditwheel repair dist/*.whl
- - name: Build wheels for Python 3.9
+ - name: Install and test wheel for Python 3.8
+ run: |
+ $PYTHON38/bin/python -m pip install --user pytest build_38/src/python/dist/*.whl
+ $PYTHON38/bin/python -m pytest src/python/test/test_alpha_complex.py
+ - name: Build wheel for Python 3.9
run: |
mkdir build_39
cd build_39
@@ -54,6 +70,10 @@ jobs:
cd src/python
$PYTHON39/bin/python setup.py bdist_wheel
auditwheel repair dist/*.whl
+ - name: Install and test wheel for Python 3.9
+ run: |
+ $PYTHON39/bin/python -m pip install --user pytest build_39/src/python/dist/*.whl
+ $PYTHON39/bin/python -m pytest src/python/test/test_alpha_complex.py
- name: Publish on PyPi
env:
TWINE_USERNAME: __token__
@@ -63,4 +83,4 @@ jobs:
$PYTHON39/bin/python -m twine upload build_36/src/python/wheelhouse/*
$PYTHON39/bin/python -m twine upload build_37/src/python/wheelhouse/*
$PYTHON39/bin/python -m twine upload build_38/src/python/wheelhouse/*
- $PYTHON39/bin/python -m twine upload build_39/src/python/wheelhouse/* \ No newline at end of file
+ $PYTHON39/bin/python -m twine upload build_39/src/python/wheelhouse/*
diff --git a/.github/workflows/pip-packaging-osx.yml b/.github/workflows/pip-packaging-osx.yml
index 56309b88..120c15b6 100644
--- a/.github/workflows/pip-packaging-osx.yml
+++ b/.github/workflows/pip-packaging-osx.yml
@@ -34,6 +34,10 @@ jobs:
cmake -DCMAKE_BUILD_TYPE=Release -DPython_ADDITIONAL_VERSIONS=3 ..
cd src/python
python setup.py bdist_wheel
+ - name: Install and test python wheel
+ run: |
+ python -m pip install --user pytest build/src/python/dist/*.whl
+ python -m pytest src/python/test/test_alpha_complex.py
- name: Publish on PyPi
env:
TWINE_USERNAME: __token__
diff --git a/.github/workflows/pip-packaging-windows.yml b/.github/workflows/pip-packaging-windows.yml
index a428eaba..f387c5ff 100644
--- a/.github/workflows/pip-packaging-windows.yml
+++ b/.github/workflows/pip-packaging-windows.yml
@@ -22,10 +22,19 @@ jobs:
architecture: x64
- name: Install dependencies
run: |
- vcpkg update
- vcpkg upgrade --no-dry-run
- type c:/vcpkg/ports/cgal/portfile.cmake
- vcpkg install eigen3 cgal --triplet x64-windows
+ cd c:/vcpkg
+ git fetch --all --tags
+ git checkout 2020.11-1
+ bootstrap-vcpkg.bat
+ set VCPKG_BUILD_TYPE=release
+ vcpkg install eigen3 mpfr boost-accumulators boost-algorithm boost-bimap boost-callable-traits boost-concept-check boost-container boost-core boost-detail boost-filesystem boost-functional boost-fusion boost-geometry boost-graph boost-heap boost-intrusive boost-iostreams boost-iterator boost-lambda boost-logic boost-math boost-mpl boost-multi-index boost-multiprecision boost-numeric-conversion boost-optional boost-parameter boost-pool boost-preprocessor boost-property-map boost-property-tree boost-ptr-container boost-random boost-range boost-serialization boost-spirit boost-thread boost-tuple boost-type-traits boost-units boost-utility boost-variant --triplet x64-windows
+ vcpkg version
+ ls C:/vcpkg/installed/x64-windows/bin
+ Invoke-WebRequest https://github.com/CGAL/cgal/releases/download/v5.2.1/CGAL-5.2.1.zip -OutFile CGAL-5.2.1.zip
+ Expand-Archive -Path CGAL-5.2.1.zip -DestinationPath .
+ cd CGAL-5.2.1
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_TOOLCHAIN_FILE=c:/vcpkg/scripts/buildsystems/vcpkg.cmake -DVCPKG_TARGET_TRIPLET=x64-windows -DGMP_INCLUDE_DIR=c:/vcpkg/installed/x64-windows/include -DGMP_LIBRARIES=c:/vcpkg/installed/x64-windows/bin/mpir.dll .
+ cd ${{ github.workspace }}
python -m pip install --user -r ext/gudhi-deploy/build-requirements.txt
python -m pip install --user twine
python -m pip list
@@ -33,11 +42,20 @@ jobs:
run: |
mkdir build
cd build
- cmake -DCMAKE_BUILD_TYPE=Release -DGMP_INCLUDE_DIR="c:/vcpkg/installed/x64-windows/include" -DGMP_LIBRARIES="c:/vcpkg/installed/x64-windows/lib/mpir.lib" -DGMP_LIBRARIES_DIR="c:/vcpkg/installed/x64-windows/lib" -DCMAKE_TOOLCHAIN_FILE=C:/vcpkg/scripts/buildsystems/vcpkg.cmake -DVCPKG_TARGET_TRIPLET=x64-windows -DPython_ADDITIONAL_VERSIONS=3 ..
+ cmake -DCGAL_DIR=c:/vcpkg/CGAL-5.2.1 -DCMAKE_BUILD_TYPE=Release -DCMAKE_TOOLCHAIN_FILE=c:/vcpkg/scripts/buildsystems/vcpkg.cmake -DVCPKG_TARGET_TRIPLET=x64-windows -DGMP_INCLUDE_DIR=c:/vcpkg/installed/x64-windows/include -DGMP_LIBRARIES=c:/vcpkg/installed/x64-windows/bin/mpir.dll ..
cd src/python
cp c:/vcpkg/installed/x64-windows/bin/mpfr.dll gudhi/
cp c:/vcpkg/installed/x64-windows/bin/mpir.dll gudhi/
python setup.py bdist_wheel
+ ls dist
+ - name: Install and test python wheel
+ run: |
+ cd ${{ github.workspace }}
+ cd build/src/python/dist/
+ Get-ChildItem *.whl | ForEach-Object{python -m pip install --user $_.Name}
+ cd ${{ github.workspace }}
+ python -m pip install --user pytest
+ python -m pytest src/python/test/test_alpha_complex.py
- name: Publish on PyPi
env:
TWINE_USERNAME: __token__