summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2021-04-29 11:23:43 +0200
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2021-04-29 11:23:43 +0200
commit8cf6bbe7e2bd7c71cb44872aba772a1c4caf06a9 (patch)
tree4959aa7180dc3e931642c0d387c613bb5b914f36
parent70387c34b638972b7c51017b81949f32ddd63e39 (diff)
numpy.take_along_axis used in knn requires numpy>=1.15.0
-rw-r--r--.github/build-requirements.txt5
-rw-r--r--.github/test-requirements.txt15
-rw-r--r--src/python/doc/installation.rst2
-rw-r--r--src/python/setup.py.in4
4 files changed, 3 insertions, 23 deletions
diff --git a/.github/build-requirements.txt b/.github/build-requirements.txt
deleted file mode 100644
index 7de60d23..00000000
--- a/.github/build-requirements.txt
+++ /dev/null
@@ -1,5 +0,0 @@
-setuptools
-wheel
-numpy
-Cython
-pybind11 \ No newline at end of file
diff --git a/.github/test-requirements.txt b/.github/test-requirements.txt
deleted file mode 100644
index d0803574..00000000
--- a/.github/test-requirements.txt
+++ /dev/null
@@ -1,15 +0,0 @@
-pytest
-pytest-cov
-sphinx
-sphinxcontrib-bibtex==1.0.0
-sphinx-paramlinks
-matplotlib
-scipy
-scikit-learn
-POT
-tensorflow
-tensorflow-addons
-torch<1.5
-pykeops
-hnswlib
-eagerpy
diff --git a/src/python/doc/installation.rst b/src/python/doc/installation.rst
index 2881055f..9c16b04e 100644
--- a/src/python/doc/installation.rst
+++ b/src/python/doc/installation.rst
@@ -41,7 +41,7 @@ there.
The library uses c++14 and requires `Boost <https://www.boost.org/>`_ :math:`\geq` 1.56.0,
`CMake <https://www.cmake.org/>`_ :math:`\geq` 3.5 to generate makefiles,
-`NumPy <http://numpy.org>`_, `Cython <https://www.cython.org/>`_ and
+`NumPy <http://numpy.org>`_ :math:`\geq` 1.15.0, `Cython <https://www.cython.org/>`_ and
`pybind11 <https://github.com/pybind/pybind11>`_ to compile
the GUDHI Python module.
It is a multi-platform library and compiles on Linux, Mac OSX and Visual
diff --git a/src/python/setup.py.in b/src/python/setup.py.in
index 65f5446e..759ec8d8 100644
--- a/src/python/setup.py.in
+++ b/src/python/setup.py.in
@@ -85,7 +85,7 @@ setup(
long_description_content_type='text/x-rst',
long_description=long_description,
ext_modules = ext_modules,
- install_requires = ['numpy >= 1.9',],
- setup_requires = ['cython','numpy >= 1.9','pybind11',],
+ install_requires = ['numpy >= 1.15.0',],
+ setup_requires = ['cython','numpy >= 1.15.0','pybind11',],
package_data={"": ["*.dll"], },
)