summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Glisse <marc.glisse@inria.fr>2019-11-15 22:45:15 +0100
committerMarc Glisse <marc.glisse@inria.fr>2019-11-15 22:45:15 +0100
commit908679b72c215d1914d8e3956126fa44367b937f (patch)
tree48cda77d91f4c914ed8d26ea47adb2a9bb4eb7a6
parentb2d81dd8ee2ed7e1269eb16816f9af6794305046 (diff)
The big rename: sktda -> representations
-rw-r--r--src/python/CMakeLists.txt4
-rw-r--r--src/python/doc/index.rst2
-rw-r--r--src/python/doc/representations.rst (renamed from src/python/doc/sktda.rst)10
-rw-r--r--src/python/doc/representations_sum.inc (renamed from src/python/doc/sktda_sum.inc)2
-rwxr-xr-xsrc/python/example/diagram_vectorizations_distances_kernels.py2
-rw-r--r--src/python/gudhi/representations/__init__.py (renamed from src/python/gudhi/sktda/__init__.py)0
-rw-r--r--src/python/gudhi/representations/kernel_methods.py (renamed from src/python/gudhi/sktda/kernel_methods.py)0
-rw-r--r--src/python/gudhi/representations/metrics.py (renamed from src/python/gudhi/sktda/metrics.py)0
-rw-r--r--src/python/gudhi/representations/preprocessing.py (renamed from src/python/gudhi/sktda/preprocessing.py)0
-rw-r--r--src/python/gudhi/representations/vector_methods.py (renamed from src/python/gudhi/sktda/vector_methods.py)0
10 files changed, 10 insertions, 10 deletions
diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
index d131b920..2c568b66 100644
--- a/src/python/CMakeLists.txt
+++ b/src/python/CMakeLists.txt
@@ -50,7 +50,7 @@ if(PYTHONINTERP_FOUND)
set(GUDHI_PYTHON_MODULES "${GUDHI_PYTHON_MODULES}'euclidean_witness_complex', ")
set(GUDHI_PYTHON_MODULES "${GUDHI_PYTHON_MODULES}'euclidean_strong_witness_complex', ")
# Modules that should not be auto-imported in __init__.py
- set(GUDHI_PYTHON_MODULES_EXTRA "${GUDHI_PYTHON_MODULES_EXTRA}'sktda', ")
+ set(GUDHI_PYTHON_MODULES_EXTRA "${GUDHI_PYTHON_MODULES_EXTRA}'representations', ")
set(GUDHI_PYTHON_MODULES_EXTRA "${GUDHI_PYTHON_MODULES_EXTRA}'wasserstein', ")
add_gudhi_debug_info("Python version ${PYTHON_VERSION_STRING}")
@@ -208,7 +208,7 @@ if(PYTHONINTERP_FOUND)
# Other .py files
file(COPY "gudhi/persistence_graphical_tools.py" DESTINATION "${CMAKE_CURRENT_BINARY_DIR}/gudhi")
- file(COPY "gudhi/sktda" DESTINATION "${CMAKE_CURRENT_BINARY_DIR}/gudhi/")
+ file(COPY "gudhi/representations" DESTINATION "${CMAKE_CURRENT_BINARY_DIR}/gudhi/")
file(COPY "gudhi/wasserstein.py" DESTINATION "${CMAKE_CURRENT_BINARY_DIR}/gudhi")
add_custom_command(
diff --git a/src/python/doc/index.rst b/src/python/doc/index.rst
index f8dd3c2f..1ef08096 100644
--- a/src/python/doc/index.rst
+++ b/src/python/doc/index.rst
@@ -81,7 +81,7 @@ Wasserstein distance
Persistence representations
===========================
-.. include:: sktda_sum.inc
+.. include:: representations_sum.inc
Persistence graphical tools
===========================
diff --git a/src/python/doc/sktda.rst b/src/python/doc/representations.rst
index 9acec616..3db1c95a 100644
--- a/src/python/doc/sktda.rst
+++ b/src/python/doc/representations.rst
@@ -3,33 +3,33 @@
.. To get rid of WARNING: document isn't included in any toctree
===================================
-sktda reference manual
+Representations reference manual
===================================
Preprocessing
-------------
-.. automodule:: gudhi.sktda.preprocessing
+.. automodule:: gudhi.representations.preprocessing
:members:
:special-members:
:show-inheritance:
Vector methods
--------------
-.. automodule:: gudhi.sktda.vector_methods
+.. automodule:: gudhi.representations.vector_methods
:members:
:special-members:
:show-inheritance:
Kernel methods
--------------
-.. automodule:: gudhi.sktda.kernel_methods
+.. automodule:: gudhi.representations.kernel_methods
:members:
:special-members:
:show-inheritance:
Metrics
-------
-.. automodule:: gudhi.sktda.metrics
+.. automodule:: gudhi.representations.metrics
:members:
:special-members:
:show-inheritance:
diff --git a/src/python/doc/sktda_sum.inc b/src/python/doc/representations_sum.inc
index a0f77e7e..7b167a17 100644
--- a/src/python/doc/sktda_sum.inc
+++ b/src/python/doc/representations_sum.inc
@@ -10,5 +10,5 @@
| | | |
| | | :Requires: scikit-learn |
+------------------------------------------------------------------+----------------------------------------------------------------+-----------------------------------------------+
- | * :doc:`sktda` |
+ | * :doc:`representations` |
+------------------------------------------------------------------+----------------------------------------------------------------------------------------------------------------+
diff --git a/src/python/example/diagram_vectorizations_distances_kernels.py b/src/python/example/diagram_vectorizations_distances_kernels.py
index a6a36b7c..a77bbfdd 100755
--- a/src/python/example/diagram_vectorizations_distances_kernels.py
+++ b/src/python/example/diagram_vectorizations_distances_kernels.py
@@ -5,7 +5,7 @@ import numpy as np
from sklearn.kernel_approximation import RBFSampler
from sklearn.preprocessing import MinMaxScaler
-from gudhi.sktda import DiagramSelector, Clamping, Landscape, Silhouette, BettiCurve, ComplexPolynomial,\
+from gudhi.representations import DiagramSelector, Clamping, Landscape, Silhouette, BettiCurve, ComplexPolynomial,\
TopologicalVector, DiagramScaler, BirthPersistenceTransform,\
PersistenceImage, PersistenceWeightedGaussianKernel, Entropy, \
PersistenceScaleSpaceKernel, SlicedWassersteinDistance,\
diff --git a/src/python/gudhi/sktda/__init__.py b/src/python/gudhi/representations/__init__.py
index f020248d..f020248d 100644
--- a/src/python/gudhi/sktda/__init__.py
+++ b/src/python/gudhi/representations/__init__.py
diff --git a/src/python/gudhi/sktda/kernel_methods.py b/src/python/gudhi/representations/kernel_methods.py
index c855d2be..c855d2be 100644
--- a/src/python/gudhi/sktda/kernel_methods.py
+++ b/src/python/gudhi/representations/kernel_methods.py
diff --git a/src/python/gudhi/sktda/metrics.py b/src/python/gudhi/representations/metrics.py
index c512cb82..c512cb82 100644
--- a/src/python/gudhi/sktda/metrics.py
+++ b/src/python/gudhi/representations/metrics.py
diff --git a/src/python/gudhi/sktda/preprocessing.py b/src/python/gudhi/representations/preprocessing.py
index 83227ca1..83227ca1 100644
--- a/src/python/gudhi/sktda/preprocessing.py
+++ b/src/python/gudhi/representations/preprocessing.py
diff --git a/src/python/gudhi/sktda/vector_methods.py b/src/python/gudhi/representations/vector_methods.py
index bf32f18e..bf32f18e 100644
--- a/src/python/gudhi/sktda/vector_methods.py
+++ b/src/python/gudhi/representations/vector_methods.py