summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2022-01-14 09:49:57 +0100
committerGard Spreemann <gspr@nonempty.org>2022-01-14 09:49:57 +0100
commitb32f71f0cee1f8609cfb4205bddea088c4e4094b (patch)
tree9a8f04863ed0b82b11228ff44e55ec6ff4c39431
parent415403affce5dc7fdb63aab3b98f9acfadd063a1 (diff)
Rebase patches
-rw-r--r--debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch66
-rw-r--r--debian/patches/0002-Use-system-MathJax.patch4
-rw-r--r--debian/patches/0003-Offline-header-for-docs.patch6
-rw-r--r--debian/patches/0004-Disable-Sphinx.patch4
-rw-r--r--debian/patches/0005-Install-Python-module-in-correct-location.patch21
-rw-r--r--debian/patches/0006-Move-towards-reproducible-builds.patch23
-rw-r--r--debian/patches/0007-Turn-positional-argument-into-keyword-argument.patch23
-rw-r--r--debian/patches/series3
8 files changed, 20 insertions, 130 deletions
diff --git a/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch b/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
index 6151ae79..82abd0ed 100644
--- a/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
+++ b/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
@@ -3,12 +3,10 @@ Date: Wed, 25 Sep 2019 15:12:45 +0200
Subject: Disable tests that use DFSG-deleted data files.
---
- src/Nerve_GIC/example/CMakeLists.txt | 5 ----
- src/Nerve_GIC/utilities/CMakeLists.txt | 8 ------
- src/Persistent_cohomology/example/CMakeLists.txt | 12 ---------
- src/Simplex_tree/example/CMakeLists.txt | 2 --
- src/python/CMakeLists.txt | 31 +-----------------------
- 5 files changed, 1 insertion(+), 57 deletions(-)
+ src/Nerve_GIC/example/CMakeLists.txt | 5 -----
+ src/Nerve_GIC/utilities/CMakeLists.txt | 8 --------
+ src/python/CMakeLists.txt | 29 -----------------------------
+ 3 files changed, 42 deletions(-)
diff --git a/src/Nerve_GIC/example/CMakeLists.txt b/src/Nerve_GIC/example/CMakeLists.txt
index 4b0f467..110212d 100644
@@ -48,49 +46,13 @@ index 65a08d9..3f16db9 100644
install(TARGETS Nerve DESTINATION bin)
install(TARGETS VoronoiGIC DESTINATION bin)
-diff --git a/src/Persistent_cohomology/example/CMakeLists.txt b/src/Persistent_cohomology/example/CMakeLists.txt
-index c68c652..9a15a89 100644
---- a/src/Persistent_cohomology/example/CMakeLists.txt
-+++ b/src/Persistent_cohomology/example/CMakeLists.txt
-@@ -33,18 +33,6 @@ if(TARGET Boost::program_options)
- "${CMAKE_SOURCE_DIR}/data/points/Kl.off" "-r" "0.16" "-d" "3" "-p" "3" "-m" "100")
- endif()
-
--if(TARGET Boost::program_options)
-- add_executable(persistence_from_file persistence_from_file.cpp)
-- target_link_libraries(persistence_from_file Boost::program_options)
-- if (TBB_FOUND)
-- target_link_libraries(persistence_from_file ${TBB_LIBRARIES})
-- endif()
-- add_test(NAME Persistent_cohomology_example_from_file_3_2_0 COMMAND $<TARGET_FILE:persistence_from_file>
-- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "2" "-m" "0")
-- add_test(NAME Persistent_cohomology_example_from_file_3_3_100 COMMAND $<TARGET_FILE:persistence_from_file>
-- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "3" "-m" "100")
--endif()
--
- if(GMP_FOUND)
- if(GMPXX_FOUND)
- if(TARGET Boost::program_options)
-diff --git a/src/Simplex_tree/example/CMakeLists.txt b/src/Simplex_tree/example/CMakeLists.txt
-index 73b2c6f..a6dd0b1 100644
---- a/src/Simplex_tree/example/CMakeLists.txt
-+++ b/src/Simplex_tree/example/CMakeLists.txt
-@@ -28,8 +28,6 @@ if(GMP_FOUND AND NOT CGAL_VERSION VERSION_LESS 4.11.0)
- if (TBB_FOUND)
- target_link_libraries(Simplex_tree_example_alpha_shapes_3_from_off ${TBB_LIBRARIES})
- endif()
-- add_test(NAME Simplex_tree_example_alpha_shapes_3_from_off COMMAND $<TARGET_FILE:Simplex_tree_example_alpha_shapes_3_from_off>
-- "${CMAKE_SOURCE_DIR}/data/points/bunny_5000.off")
-
- endif()
-
diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
-index 5c1402a..a45e13a 100644
+index 1314b44..7edac67 100644
--- a/src/python/CMakeLists.txt
+++ b/src/python/CMakeLists.txt
-@@ -386,36 +386,7 @@ if(PYTHONINTERP_FOUND)
- add_gudhi_py_test(test_bottleneck_distance)
- endif()
+@@ -414,35 +414,6 @@ if(PYTHONINTERP_FOUND)
+
+ add_gudhi_py_test(test_bottleneck_distance)
- # Cover complex
- file(COPY ${CMAKE_SOURCE_DIR}/data/points/human.off DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
@@ -98,31 +60,29 @@ index 5c1402a..a45e13a 100644
- file(COPY ${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1 DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
- add_test(NAME cover_complex_nerve_example_py_test
- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
-- COMMAND ${CMAKE_COMMAND} -E env "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}"
+- COMMAND ${CMAKE_COMMAND} -E env "${GUDHI_PYTHON_PATH_ENV}"
- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/nerve_of_a_covering.py"
- -f human.off -c 2 -r 10 -g 0.3)
-
- add_test(NAME cover_complex_coordinate_gic_example_py_test
- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
-- COMMAND ${CMAKE_COMMAND} -E env "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}"
+- COMMAND ${CMAKE_COMMAND} -E env "${GUDHI_PYTHON_PATH_ENV}"
- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/coordinate_graph_induced_complex.py"
- -f human.off -c 0 -v)
-
- add_test(NAME cover_complex_functional_gic_example_py_test
- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
-- COMMAND ${CMAKE_COMMAND} -E env "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}"
+- COMMAND ${CMAKE_COMMAND} -E env "${GUDHI_PYTHON_PATH_ENV}"
- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/functional_graph_induced_complex.py"
- -o lucky_cat.off
- -f lucky_cat_PCA1 -v)
-
- add_test(NAME cover_complex_voronoi_gic_example_py_test
- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
-- COMMAND ${CMAKE_COMMAND} -E env "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}"
+- COMMAND ${CMAKE_COMMAND} -E env "${GUDHI_PYTHON_PATH_ENV}"
- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/voronoi_graph_induced_complex.py"
- -f human.off -n 700 -v)
-
-- add_gudhi_py_test(test_cover_complex)
-+
+ add_gudhi_py_test(test_cover_complex)
endif (NOT CGAL_VERSION VERSION_LESS 4.11.0)
- if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
diff --git a/debian/patches/0002-Use-system-MathJax.patch b/debian/patches/0002-Use-system-MathJax.patch
index 2985548e..8123a42d 100644
--- a/debian/patches/0002-Use-system-MathJax.patch
+++ b/debian/patches/0002-Use-system-MathJax.patch
@@ -7,10 +7,10 @@ Subject: Use system MathJax.
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/Doxyfile.in b/src/Doxyfile.in
-index 49e781b..52b8cbe 100644
+index ae8db1a..9f697a5 100644
--- a/src/Doxyfile.in
+++ b/src/Doxyfile.in
-@@ -1441,7 +1441,7 @@ MATHJAX_FORMAT = HTML-CSS
+@@ -1526,7 +1526,7 @@ MATHJAX_FORMAT = HTML-CSS
# The default value is: http://cdn.mathjax.org/mathjax/latest.
# This tag requires that the tag USE_MATHJAX is set to YES.
diff --git a/debian/patches/0003-Offline-header-for-docs.patch b/debian/patches/0003-Offline-header-for-docs.patch
index b6dba1ab..8392fa54 100644
--- a/debian/patches/0003-Offline-header-for-docs.patch
+++ b/debian/patches/0003-Offline-header-for-docs.patch
@@ -7,14 +7,14 @@ Subject: Offline header for docs.
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/Doxyfile.in b/src/Doxyfile.in
-index 52b8cbe..f516ef7 100644
+index 9f697a5..a1a2f6b 100644
--- a/src/Doxyfile.in
+++ b/src/Doxyfile.in
-@@ -1046,7 +1046,7 @@ HTML_FILE_EXTENSION = .html
+@@ -1127,7 +1127,7 @@ HTML_FILE_EXTENSION = .html
# of the possible markers and block names see the documentation.
# This tag requires that the tag GENERATE_HTML is set to YES.
--HTML_HEADER = doc/common/header.html
+-HTML_HEADER = @GUDHI_DOXYGEN_COMMON_DOC_PATH@/header.html
+HTML_HEADER = doc/common/offline_header.html
# The HTML_FOOTER tag can be used to specify a user-defined HTML footer for each
diff --git a/debian/patches/0004-Disable-Sphinx.patch b/debian/patches/0004-Disable-Sphinx.patch
index 2aee22ff..de66bbfb 100644
--- a/debian/patches/0004-Disable-Sphinx.patch
+++ b/debian/patches/0004-Disable-Sphinx.patch
@@ -7,10 +7,10 @@ Subject: Disable Sphinx.
1 file changed, 1 deletion(-)
diff --git a/src/cmake/modules/GUDHI_third_party_libraries.cmake b/src/cmake/modules/GUDHI_third_party_libraries.cmake
-index e156687..aa1c4bb 100644
+index 21c9d47..d22697c 100644
--- a/src/cmake/modules/GUDHI_third_party_libraries.cmake
+++ b/src/cmake/modules/GUDHI_third_party_libraries.cmake
-@@ -147,7 +147,6 @@ if( PYTHONINTERP_FOUND )
+@@ -148,7 +148,6 @@ if( PYTHONINTERP_FOUND )
find_python_module("matplotlib")
find_python_module("numpy")
find_python_module("scipy")
diff --git a/debian/patches/0005-Install-Python-module-in-correct-location.patch b/debian/patches/0005-Install-Python-module-in-correct-location.patch
deleted file mode 100644
index a395cdd8..00000000
--- a/debian/patches/0005-Install-Python-module-in-correct-location.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From: Gard Spreemann <gspr@nonempty.org>
-Date: Thu, 26 Sep 2019 13:26:22 +0200
-Subject: Install Python module in correct location.
-
----
- src/python/CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
-index a45e13a..4d56f58 100644
---- a/src/python/CMakeLists.txt
-+++ b/src/python/CMakeLists.txt
-@@ -274,7 +274,7 @@ if(PYTHONINTERP_FOUND)
- add_custom_target(python ALL DEPENDS gudhi.so
- COMMENT "Do not forget to add ${CMAKE_CURRENT_BINARY_DIR}/ to your PYTHONPATH before using examples or tests")
-
-- install(CODE "execute_process(COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/setup.py install)")
-+ install(CODE "execute_process(COMMAND ${PYTHON_EXECUTABLE} setup.py install --root=${CMAKE_SOURCE_DIR}/debian/tmp --single-version-externally-managed --install-layout=deb WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR})")
-
- # Documentation generation is available through sphinx - requires all modules
- # Make it first as sphinx test is by far the longest test which is nice when testing in parallel
diff --git a/debian/patches/0006-Move-towards-reproducible-builds.patch b/debian/patches/0006-Move-towards-reproducible-builds.patch
deleted file mode 100644
index 7d6ae95d..00000000
--- a/debian/patches/0006-Move-towards-reproducible-builds.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From: Gard Spreemann <gspr@nonempty.org>
-Date: Tue, 21 Jan 2020 10:39:23 +0100
-Subject: Move towards reproducible builds.
-
-This does not take us all the way there, and probably breaks doctest,
-but since we're not doing Sphinx stuff yet anyway, that is ok for now.
----
- src/python/gudhi/__init__.py.in | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/python/gudhi/__init__.py.in b/src/python/gudhi/__init__.py.in
-index 3043201..ef6389e 100644
---- a/src/python/gudhi/__init__.py.in
-+++ b/src/python/gudhi/__init__.py.in
-@@ -15,7 +15,7 @@ __copyright__ = "Copyright (C) 2016 Inria"
- __license__ = "https://gudhi.inria.fr/licensing/"
- __version__ = "@GUDHI_VERSION@"
- # This variable is used by doctest to find files
--__root_source_dir__ = "@CMAKE_SOURCE_DIR@"
-+__root_source_dir__ = "."
- __debug_info__ = @GUDHI_PYTHON_DEBUG_INFO@
-
- __all__ = [@GUDHI_PYTHON_MODULES@ @GUDHI_PYTHON_MODULES_EXTRA@]
diff --git a/debian/patches/0007-Turn-positional-argument-into-keyword-argument.patch b/debian/patches/0007-Turn-positional-argument-into-keyword-argument.patch
deleted file mode 100644
index 109e18ee..00000000
--- a/debian/patches/0007-Turn-positional-argument-into-keyword-argument.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From: Gard Spreemann <gspr@nonempty.org>
-Date: Thu, 23 Dec 2021 16:33:25 +0100
-Subject: Turn positional argument into keyword argument
-
-After the 0.24.x series, Scikit-Learn got rid of all of most of its
-positional arguments in favor of keyword ones.
----
- src/python/gudhi/point_cloud/knn.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/python/gudhi/point_cloud/knn.py b/src/python/gudhi/point_cloud/knn.py
-index 994be3b..829bf1b 100644
---- a/src/python/gudhi/point_cloud/knn.py
-+++ b/src/python/gudhi/point_cloud/knn.py
-@@ -111,7 +111,7 @@ class KNearestNeighbors:
- nargs = {
- k: v for k, v in self.params.items() if k in {"p", "n_jobs", "metric_params", "algorithm", "leaf_size"}
- }
-- self.nn = NearestNeighbors(self.k, metric=self.metric, **nargs)
-+ self.nn = NearestNeighbors(n_neighbors=self.k, metric=self.metric, **nargs)
- self.nn.fit(X)
-
- if self.params["implementation"] == "hnsw":
diff --git a/debian/patches/series b/debian/patches/series
index 7167006d..ab3337cf 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -2,6 +2,3 @@
0002-Use-system-MathJax.patch
0003-Offline-header-for-docs.patch
0004-Disable-Sphinx.patch
-0005-Install-Python-module-in-correct-location.patch
-0006-Move-towards-reproducible-builds.patch
-0007-Turn-positional-argument-into-keyword-argument.patch