summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHind-M <hind.montassif@gmail.com>2021-10-06 10:19:33 +0200
committerHind-M <hind.montassif@gmail.com>2021-10-06 10:19:33 +0200
commite9a676d7aa9d27595951f1f4f14ac419641234b4 (patch)
tree05cc39ba6099d5a71139c4512135a7c6cbfd0dc8
parentd3970dbbc16993d348092899eb8fcd1ea1aceb8d (diff)
Replace CGAL_FOUND flag with version check of CGAL_WITH_EIGEN3_VERSION
-rw-r--r--src/Cech_complex/benchmark/CMakeLists.txt2
-rw-r--r--src/Cech_complex/example/CMakeLists.txt2
-rw-r--r--src/Cech_complex/test/CMakeLists.txt2
-rw-r--r--src/Cech_complex/utilities/CMakeLists.txt2
4 files changed, 4 insertions, 4 deletions
diff --git a/src/Cech_complex/benchmark/CMakeLists.txt b/src/Cech_complex/benchmark/CMakeLists.txt
index ccd1b324..dd7f3f6c 100644
--- a/src/Cech_complex/benchmark/CMakeLists.txt
+++ b/src/Cech_complex/benchmark/CMakeLists.txt
@@ -1,6 +1,6 @@
project(Cech_complex_benchmark)
-if (CGAL_FOUND)
+if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
# Do not forget to copy test files in current binary dir
file(COPY "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
diff --git a/src/Cech_complex/example/CMakeLists.txt b/src/Cech_complex/example/CMakeLists.txt
index 52dec63f..2b6a29a3 100644
--- a/src/Cech_complex/example/CMakeLists.txt
+++ b/src/Cech_complex/example/CMakeLists.txt
@@ -1,6 +1,6 @@
project(Cech_complex_examples)
-if (CGAL_FOUND)
+if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
if (TARGET Boost::program_options)
add_executable ( Cech_complex_example_step_by_step cech_complex_step_by_step.cpp )
target_link_libraries(Cech_complex_example_step_by_step Boost::program_options)
diff --git a/src/Cech_complex/test/CMakeLists.txt b/src/Cech_complex/test/CMakeLists.txt
index 8e725f50..66d796a7 100644
--- a/src/Cech_complex/test/CMakeLists.txt
+++ b/src/Cech_complex/test/CMakeLists.txt
@@ -1,4 +1,4 @@
-if (CGAL_FOUND)
+if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
include(GUDHI_boost_test)
add_executable ( Cech_complex_test_unit test_cech_complex.cpp )
diff --git a/src/Cech_complex/utilities/CMakeLists.txt b/src/Cech_complex/utilities/CMakeLists.txt
index efe40e57..3c9c0f73 100644
--- a/src/Cech_complex/utilities/CMakeLists.txt
+++ b/src/Cech_complex/utilities/CMakeLists.txt
@@ -1,4 +1,4 @@
-if (CGAL_FOUND)
+if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
project(Cech_complex_utilities)
if (TARGET Boost::program_options)