summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-01-06 16:49:25 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-01-06 16:49:25 +0000
commit059c906152ca90608238bc82b07d8e28e18218dc (patch)
tree653b9e2cd5271ff8d6b5476c487e998c35c3c7f8 /CMakeLists.txt
parent5b28454c34bab66bad9c95b2b179af0c2e809efd (diff)
CMake modification for Windows/Linux comilation
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/trunk@405 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 76e81b3769a39f13b14be50f5380ed2254c92c94
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 10 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bffba902..32589371 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,8 +19,10 @@ else()
set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE}")
endif()
-# BOOST ISSUE result_of vs C++11
-add_definitions(-DBOOST_RESULT_OF_USE_DECLTYPE)
+set(Boost_USE_STATIC_LIBS ON)
+set(Boost_USE_MULTITHREADED ON)
+set(Boost_USE_STATIC_RUNTIME OFF)
+
find_package(Boost)
find_package(GMP)
if(GMP_FOUND)
@@ -56,9 +58,15 @@ endfunction(cpplint_add_tests)
if(NOT Boost_FOUND)
message(FATAL_ERROR "NOTICE: This demo requires Boost and will not be compiled.")
else()
+ # BOOST ISSUE result_of vs C++11
+ add_definitions(-DBOOST_RESULT_OF_USE_DECLTYPE)
+ # BOOST ISSUE with Libraries name resolution under Windows
+ add_definitions(-DBOOST_ALL_NO_LIB)
+
INCLUDE_DIRECTORIES(${Boost_INCLUDE_DIRS})
LINK_DIRECTORIES(${Boost_LIBRARY_DIRS})
+ message(STATUS "boost include dirs:" ${Boost_INCLUDE_DIRS})
include_directories(src/common/include/)
include_directories(src/Contraction/include/)