summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-06-18 14:21:31 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-06-18 14:21:31 +0000
commit56e89b6b7666dec86a70f6a30f08ef8b7960eb21 (patch)
treea43dd7705fcf7435df726e5bc5123662abc8ea4d /CMakeLists.txt
parent77b57ae69fa2042b652d91d8015c1d9533176090 (diff)
Moved alphashapedoc.off in data/points
Moved Delaunay triangulation OFF files read and write in src/common Delaunay triangulation OFF files read and write documentation, examples and tests git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/alphashapes@623 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: e03902736a79436e97dbf77a88504f3faa8bd9c6
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 01108db9..86b4e2b6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -42,6 +42,11 @@ if (PYTHON_PATH)
message("python found in ${PYTHON_PATH}")
endif()
+FIND_PROGRAM( DIFF_PATH diff )
+if (DIFF_PATH)
+ message("diff found in ${DIFF_PATH}")
+endif()
+
# Function to add_test cpplint on each header file of the Gudhi module
function(cpplint_add_tests the_directory)
if (PYTHON_PATH)
@@ -77,9 +82,11 @@ else()
include_directories(src/Simplex_tree/include/)
include_directories(src/Skeleton_blocker/include/)
+ add_subdirectory(src/common/example)
+ add_subdirectory(src/common/test)
add_subdirectory(src/Simplex_tree/test)
add_subdirectory(src/Simplex_tree/example)
- add_subdirectory(src/Persistent_cohomology/test)
+ #add_subdirectory(src/Persistent_cohomology/test)
add_subdirectory(src/Persistent_cohomology/example)
add_subdirectory(src/Skeleton_blocker/test)
add_subdirectory(src/Skeleton_blocker/example)