summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsalinasd <salinasd@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2014-12-17 10:06:26 +0000
committersalinasd <salinasd@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2014-12-17 10:06:26 +0000
commit0a4f78b7112ca7ae2f12a0c40e0bffd27044fc06 (patch)
tree0abd428f7d5837e6b8678dad4e71d0ac6d1d4a53 /CMakeLists.txt
parent21374a5886d76a67ab3ba69341b63f50a4e4f017 (diff)
CMakeLists.txt was not working when not GMPXX
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/trunk@364 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: da706194122da4997f171a6cb26b0f466afa0188
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ff9f14c1..c5d139fa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,10 +21,11 @@ endif()
# BOOST ISSUE result_of vs C++11
add_definitions(-DBOOST_RESULT_OF_USE_DECLTYPE)
-
find_package(Boost)
find_package(GMP)
-find_package(GMPXX)
+if(GMP_FOUND)
+ find_package(GMPXX)
+endif()
find_package(CGAL)
# Required programs for unitary tests purpose
@@ -69,7 +70,6 @@ else()
add_subdirectory(src/Persistent_cohomology/example)
add_subdirectory(src/Skeleton_blocker/test)
add_subdirectory(src/Skeleton_blocker/example)
- add_subdirectory(src/Contraction/test)
add_subdirectory(src/Contraction/example)
endif()