summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoralbert-github <albert.tests@gmail.com>2022-05-18 19:17:44 +0200
committeralbert-github <albert.tests@gmail.com>2022-05-18 19:17:44 +0200
commit0b0f67cee1e3841804f5773df5210860931a38fe (patch)
tree314186574725cfca962cc3e9518a59f7f85c9df4 /CMakeLists.txt
parentc7afe82e863eb91d122d34f1d34255c04e27b51f (diff)
Documentation: make it easier to build only the documentation
Introduce the possibility: ``` -Dbuild_documentation_only=ON ``` so that only the doxygen documentation can be build and we don't have to resort to installing all kinds of sub packages like Boost or manipulate the CMake files:w
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 10 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ac877eea..bff6d74d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,3 +1,6 @@
+
+option(build_documentation_only "Build only the documentation with doxygen." OFF)
+
cmake_minimum_required(VERSION 3.5)
project(GUDHIdev)
@@ -13,8 +16,10 @@ set(GUDHI_MISSING_MODULES "" CACHE INTERNAL "GUDHI_MISSING_MODULES")
# This variable is used by Cython CMakeLists.txt and by GUDHI_third_party_libraries to know its path
set(GUDHI_PYTHON_PATH "src/python")
-# For third parties libraries management - To be done last as CGAL updates CMAKE_MODULE_PATH
-include(GUDHI_third_party_libraries NO_POLICY_SCOPE)
+if (NOT build_documentation_only)
+ # For third parties libraries management - To be done last as CGAL updates CMAKE_MODULE_PATH
+ include(GUDHI_third_party_libraries NO_POLICY_SCOPE)
+endif()
include(GUDHI_compilation_flags)
@@ -52,7 +57,9 @@ foreach(GUDHI_MODULE ${GUDHI_MODULES})
endforeach()
endforeach()
-add_subdirectory(src/GudhUI)
+if (NOT build_documentation_only)
+ add_subdirectory(src/GudhUI)
+endif()
if (WITH_GUDHI_PYTHON)
# specific for cython module