summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-10-11 13:57:03 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-10-11 13:57:03 +0000
commit16aaf4cda5fd97da12a7f1da8b0a5168fac2e289 (patch)
tree31554bf878ca21a6330a4a28116398e400072427 /CMakeLists.txt
parent74bb6a8a2179090ffc5e65bb7e33fdff62ae4a65 (diff)
Problem of merge with tangentialcomplex branch.
Redo in an integration branch git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/tangential_integration@1701 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: fa029e8e90b3e203ea675f02098ec6fe95596f9f
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d49e0ce5..005df6d7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,7 +8,7 @@ configure_file(GUDHIVersion.cmake.in "${CMAKE_SOURCE_DIR}/GUDHIVersion.cmake" @O
find_package(Boost REQUIRED COMPONENTS system filesystem unit_test_framework chrono timer date_time program_options thread REQUIRED)
if(NOT Boost_FOUND)
- message(FATAL_ERROR "NOTICE: This demo requires Boost and will not be compiled.")
+ message(FATAL_ERROR "NOTICE: This program requires Boost and will not be compiled.")
else()
set(CMAKE_PREFIX_PATH "${CMAKE_SOURCE_DIR}/src/cmake/modules/")
@@ -49,6 +49,10 @@ else()
if(CGAL_FOUND)
message(STATUS "CGAL version: ${CGAL_VERSION}.")
include( ${CGAL_USE_FILE} )
+
+ if (NOT CGAL_VERSION VERSION_LESS 4.8.0)
+ include_directories(BEFORE "src/common/include/gudhi_patches")
+ endif()
endif()
if(MSVC)
@@ -127,6 +131,7 @@ else()
include_directories(src/Skeleton_blocker/include/)
include_directories(src/Spatial_searching/include/)
include_directories(src/Subsampling/include/)
+ include_directories(src/Tangential_complex/include/)
include_directories(src/Witness_complex/include/)
add_subdirectory(src/common/example)
@@ -148,6 +153,9 @@ else()
add_subdirectory(src/Spatial_searching/test)
add_subdirectory(src/Subsampling/example)
add_subdirectory(src/Subsampling/test)
+ add_subdirectory(src/Tangential_complex/example)
+ add_subdirectory(src/Tangential_complex/test)
+ add_subdirectory(src/Tangential_complex/benchmark)
# data points generator
add_subdirectory(data/points/generator)