summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-09-14 05:56:34 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-09-14 05:56:34 +0000
commit21eb395a9571d4b6df64b4972f6727b235369836 (patch)
tree1313dbecccf07ff6ea6bc5a027fbb99a0a0e92c4 /CMakeLists.txt
parent3757f75227b4fcbc7ab478b9a11b5bd38c2c7a0c (diff)
-Wsign-compare is included into -Wall
-pedantic is recognized by icpc (and also gcc and clang) unlike -Wpedantic git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/trunk@1494 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 6ad63e46a4e077bc4e16852eb0cb443db7c5197d
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4ce556b2..42a56fdc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -55,7 +55,7 @@ else()
# Turn off some VC++ warnings
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /wd4267 /wd4668 /wd4311 /wd4800 /wd4820 /wd4503 /wd4244 /wd4345 /wd4996 /wd4396 /wd4018")
else()
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall -Wpedantic -Wsign-compare")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall -pedantic")
endif()
if(CMAKE_BUILD_TYPE MATCHES Debug)