summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVincent Rouvreau <vincent.rouvreau@inria.fr>2022-06-29 10:03:38 +0200
committerVincent Rouvreau <vincent.rouvreau@inria.fr>2022-06-29 10:03:38 +0200
commit26a4381c6948338f935e107880cdf0789f65cb12 (patch)
tree58bb5d7c92d092e8ad22835034d7008c5b9b3008 /CMakeLists.txt
parentccb0e44f107d1d09c178620566eeefd02feb6a4e (diff)
third parties are not required when WITH_GUDHI_CPP_DOCUMENTATION_ONLY, but hera submodule is mandatory. Moved in a new cmake module
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f946e111..1164eaab 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,6 +13,8 @@ set(GUDHI_MISSING_MODULES "" CACHE INTERNAL "GUDHI_MISSING_MODULES")
# This variable is used by Cython CMakeLists.txt and by GUDHI_third_party_libraries to know its path
set(GUDHI_PYTHON_PATH "src/python")
+include(GUDHI_submodules)
+
if (NOT WITH_GUDHI_CPP_DOCUMENTATION_ONLY)
# For third parties libraries management - To be done last as CGAL updates CMAKE_MODULE_PATH
include(GUDHI_third_party_libraries NO_POLICY_SCOPE)