summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-03-02 13:14:45 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-03-02 13:14:45 +0000
commit28783add0035c46efa2754038d55f8a31ca93526 (patch)
treeb531134e09cde82b52c827f5eebab50628e05a0c /CMakeLists.txt
parentde314e530876896d58a17c8f63493782ab899dc0 (diff)
Add Boost system libraries for examples using persistence
Remove useless includes in example_nearest_landmark_table.cpp Fix list iterator not dereferencable on example nearest_landmark_table git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/relaxed-witness@2126 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: c93f00a0892737e1324a3ee8378ef7d49e6517d4
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a71ad829..07992ba1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -59,7 +59,7 @@ else()
# Turn off some VC++ warnings
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /wd4267 /wd4668 /wd4311 /wd4800 /wd4820 /wd4503 /wd4244 /wd4345 /wd4996 /wd4396 /wd4018")
else()
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall -pedantic")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall -pedantic -fsanitize=address -fno-omit-frame-pointer")
endif()
if(CMAKE_BUILD_TYPE MATCHES Debug)