summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorcjamin <cjamin@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-09-21 09:23:34 +0000
committercjamin <cjamin@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-09-21 09:23:34 +0000
commit35444924982074475df87b126a51cf4b16949a8a (patch)
treefa53714d321965d72b5252e31e3f466e7e0a2721 /CMakeLists.txt
parent227f58f39835ea33381ddb28f05ce43fcfa058b2 (diff)
parentd04f3f02858044180471fc7e38948ff73e330162 (diff)
Merge from trunk
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/subsampling_and_spatialsearching@1520 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 477d84d9b29057de29afbb77d830d9d46a8f54be
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c1535b35..d49e0ce5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,6 +18,11 @@ else()
enable_testing()
+ # For "make user_version"
+ include(${CMAKE_MODULE_PATH}/GUDHI_user_version_target.txt)
+ # For "make doxygen"
+ include(${CMAKE_MODULE_PATH}/GUDHI_doxygen_target.txt)
+
find_package(GMP)
if(GMP_FOUND)
message(STATUS "GMP_LIBRARIES = ${GMP_LIBRARIES}")
@@ -50,7 +55,7 @@ else()
# Turn off some VC++ warnings
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /wd4267 /wd4668 /wd4311 /wd4800 /wd4820 /wd4503 /wd4244 /wd4345 /wd4996 /wd4396 /wd4018")
else()
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall -Wpedantic -Wsign-compare")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall -pedantic")
endif()
if(CMAKE_BUILD_TYPE MATCHES Debug)