summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-06-28 15:55:53 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-06-28 15:55:53 +0000
commit45bef27b1c65d6692c0b1e0c9c9423ea8b6d83a8 (patch)
tree7d54ebcdc5e2f44ea2c2150b1ef00018d5235041 /CMakeLists.txt
parent27f251520f1fc355e2b7d83225d44adbf6ce63c8 (diff)
Modify FindGMPXX.cmake to set directory
Cython CmakeLists.txt for compilation and tests (still export PYTHONPATH to be solved) git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/ST_cythonize@1349 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: cc46d7ef7c34ce2bc0408eb612e5ab9241b4c9c0
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 8 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9e85be8a..c6736519 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -74,15 +74,14 @@ else()
if (GCOVR_PATH)
message("gcovr found in ${GCOVR_PATH}")
endif()
- # Required programs for unitary tests purpose
FIND_PROGRAM( GPROF_PATH gprof )
if (GPROF_PATH)
message("gprof found in ${GPROF_PATH}")
endif()
-FIND_PROGRAM( DIFF_PATH diff )
-if (DIFF_PATH)
- message("diff found in ${DIFF_PATH}")
-endif()
+ FIND_PROGRAM( DIFF_PATH diff )
+ if (DIFF_PATH)
+ message("diff found in ${DIFF_PATH}")
+ endif()
# BOOST ISSUE result_of vs C++11
add_definitions(-DBOOST_RESULT_OF_USE_DECLTYPE)
@@ -135,6 +134,10 @@ endif()
# GudhUI
add_subdirectory(src/GudhUI)
+ # This variable is used by Cython CMakeLists.txt to know its path
+ set(GUDHI_CYTHON_PATH "src/cython")
+ add_subdirectory(${GUDHI_CYTHON_PATH})
+
endif()