summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-02-28 10:14:41 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-02-28 10:14:41 +0000
commit5709f808d1a3cf0960cccd4c91a2ffde44a5867b (patch)
treeed3b7784fcf3635f942fd922c9ea29dc4bbc1391 /CMakeLists.txt
parent55a8f2f30399bc211917b099ec9b040f65378006 (diff)
Move -DBOOST_ALL_DYN_LINK from persistence to global CMakeLists.txt (also required by witness)
Add CGAL and Eigen3 required by Witness in main page Add examples to be tested for Witness git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/relaxed-witness@2115 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 33fbdf3e970c35635ae2738c1ace801f077ec750
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1346f5d9..a71ad829 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -107,6 +107,8 @@ else()
add_definitions(-DBOOST_RESULT_OF_USE_DECLTYPE)
# BOOST ISSUE with Libraries name resolution under Windows
add_definitions(-DBOOST_ALL_NO_LIB)
+ # problem with Visual Studio link on Boost program_options
+ add_definitions( -DBOOST_ALL_DYN_LINK )
INCLUDE_DIRECTORIES(${Boost_INCLUDE_DIRS})
LINK_DIRECTORIES(${Boost_LIBRARY_DIRS})