summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-06-18 14:49:07 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-06-18 14:49:07 +0000
commit669459903831d01ac1399c2d0fd2111d00392a1b (patch)
treee073865b8245272626a5066ea9524a01d4f5a170 /CMakeLists.txt
parent4f18bf5115955c764f4eb15cd600a776f1a4d9ce (diff)
parentd7c885fc4eaa06be6e6b57b8c3bd622b82a20c77 (diff)
Backmerge of last trunk modifications
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/alphashapes@625 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 8729c94e37923be0bbf943513025e7362807f041
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt29
1 files changed, 10 insertions, 19 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4596f3da..b58eadb3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,14 +32,14 @@ endif()
find_package(CGAL)
# Required programs for unitary tests purpose
-FIND_PROGRAM( LCOV_PATH lcov )
-if (LCOV_PATH)
- message("lcov found in ${LCOV_PATH}")
+FIND_PROGRAM( GCOVR_PATH gcovr )
+if (GCOVR_PATH)
+ message("gcovr found in ${GCOVR_PATH}")
endif()
-
-FIND_PROGRAM( PYTHON_PATH python )
-if (PYTHON_PATH)
- message("python found in ${PYTHON_PATH}")
+# Required programs for unitary tests purpose
+FIND_PROGRAM( GPROF_PATH gprof )
+if (GPROF_PATH)
+ message("gprof found in ${GPROF_PATH}")
endif()
FIND_PROGRAM( DIFF_PATH diff )
@@ -47,18 +47,6 @@ if (DIFF_PATH)
message("diff found in ${DIFF_PATH}")
endif()
-# Function to add_test cpplint on each header file of the Gudhi module
-function(cpplint_add_tests the_directory)
- if (PYTHON_PATH)
- # Cpplint tests on coding style
- file(GLOB files "${the_directory}/*.h" "${the_directory}/*/*.h")
- foreach(filename ${files})
- message(${filename})
- add_test("${filename}.cpplint" ${CMAKE_SOURCE_DIR}/scripts/check_google_style.sh ${filename} ${CMAKE_SOURCE_DIR}/scripts/cpplint.py)
- endforeach()
- endif()
-endfunction(cpplint_add_tests)
-
if(NOT Boost_FOUND)
message(FATAL_ERROR "NOTICE: This demo requires Boost and will not be compiled.")
@@ -97,6 +85,9 @@ else()
add_subdirectory(src/Bottleneck/example)
add_subdirectory(src/Bottleneck/test)
+ # GudhUI
+ add_subdirectory(src/GudhUI)
+
# data points generator
add_subdirectory(data/points/generator)