summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-03-31 15:40:49 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-03-31 15:40:49 +0000
commit713749e0b82988106d8e4d296a87f0594e759ce0 (patch)
tree8b4588798704deff057ef1c417c43b5c75482048 /CMakeLists.txt
parent5aee0d98ee764381f9af75f52fc747cefd3848cb (diff)
Unset CGAL_FOUND if CGAL version is less than 4.4 to fix compilation issue with CGAL 4.2.
Documentation says CGAL > 4.4 is recommended. git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/Doxygen_for_GUDHI_1.3.0@1089 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: b20d01d56e080572b067898df94ebe2eebd5893d
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9cb8b86b..94336e19 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -34,6 +34,11 @@ else()
# or even better https://cmake.org/cmake/help/v3.1/variable/CMAKE_CXX_STANDARD.html
# but it implies to use cmake version 3.1 at least.
find_package(CGAL)
+ # Only CGAL versions > 4.4 supports what Gudhi uses from CGAL
+ if (CGAL_VERSION VERSION_LESS 4.4.0)
+ message("CGAL version ${CGAL_VERSION} is considered too old to be used by Gudhi.")
+ unset(CGAL_FOUND)
+ endif()
if(CGAL_FOUND)
include( ${CGAL_USE_FILE} )
endif()