summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoralbert-github <albert.tests@gmail.com>2022-05-20 12:07:56 +0200
committeralbert-github <albert.tests@gmail.com>2022-05-20 12:07:56 +0200
commit7fff2e5e725ced71da812d9f0bede1c8e0666e2e (patch)
tree2b7ea16c92c0b86c3dbcd2ade90d7069d0c90527 /CMakeLists.txt
parent0b0f67cee1e3841804f5773df5210860931a38fe (diff)
Documentation: make it easier to build only the documentation
After review: - option is now: ``` -DWITH_GUDHI_CPP_DOCUMENTATION_ONLY=ON ``` - added some instructions to the installation description.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bff6d74d..47d87cd1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,5 @@
-option(build_documentation_only "Build only the documentation with doxygen." OFF)
+option(WITH_GUDHI_CPP_DOCUMENTATION_ONLY "Build only the GUDHI C++ documentation (with doxygen)." OFF)
cmake_minimum_required(VERSION 3.5)
@@ -16,7 +16,7 @@ set(GUDHI_MISSING_MODULES "" CACHE INTERNAL "GUDHI_MISSING_MODULES")
# This variable is used by Cython CMakeLists.txt and by GUDHI_third_party_libraries to know its path
set(GUDHI_PYTHON_PATH "src/python")
-if (NOT build_documentation_only)
+if (NOT WITH_GUDHI_CPP_DOCUMENTATION_ONLY)
# For third parties libraries management - To be done last as CGAL updates CMAKE_MODULE_PATH
include(GUDHI_third_party_libraries NO_POLICY_SCOPE)
endif()
@@ -57,7 +57,7 @@ foreach(GUDHI_MODULE ${GUDHI_MODULES})
endforeach()
endforeach()
-if (NOT build_documentation_only)
+if (NOT WITH_GUDHI_CPP_DOCUMENTATION_ONLY)
add_subdirectory(src/GudhUI)
endif()