summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSiargey Kachanovich <siargey.kachanovich@inria.fr>2019-10-17 21:44:46 +0200
committerSiargey Kachanovich <siargey.kachanovich@inria.fr>2019-10-17 21:44:46 +0200
commita24dc1591749a849ed5c356d4fafef1eb87727ae (patch)
tree4fa59c52609a4e218e2125bfb49597a30b5f238c /CMakeLists.txt
parentec9953f0dbe0f69074f25cc95442ea0012db7d98 (diff)
parenta6c844172072f1798bbbe6d5c9b4f3a548cb4c50 (diff)
Merge remote-tracking branch 'upstream/patch-1' into coxeter-integration
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 62254f3f..df292b3a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,7 +11,7 @@ set(GUDHI_MODULES "" CACHE INTERNAL "GUDHI_MODULES")
set(GUDHI_MISSING_MODULES "" CACHE INTERNAL "GUDHI_MISSING_MODULES")
# This variable is used by Cython CMakeLists.txt and by GUDHI_third_party_libraries to know its path
-set(GUDHI_CYTHON_PATH "src/cython")
+set(GUDHI_PYTHON_PATH "src/python")
# For third parties libraries management - To be done last as CGAL updates CMAKE_MODULE_PATH
include(GUDHI_third_party_libraries NO_POLICY_SCOPE)
@@ -37,6 +37,7 @@ add_gudhi_module(Skeleton_blocker)
add_gudhi_module(Spatial_searching)
add_gudhi_module(Subsampling)
add_gudhi_module(Tangential_complex)
+add_gudhi_module(Toplex_map)
add_gudhi_module(Witness_complex)
add_gudhi_module(Nerve_GIC)
@@ -54,7 +55,7 @@ add_subdirectory(src/GudhUI)
if (WITH_GUDHI_PYTHON)
# specific for cython module
- add_subdirectory(${GUDHI_CYTHON_PATH})
+ add_subdirectory(${GUDHI_PYTHON_PATH})
else()
message("++ Python module will not be compiled because WITH_GUDHI_PYTHON is set to OFF")
set(GUDHI_MISSING_MODULES ${GUDHI_MISSING_MODULES} "python")