summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorfgodi <fgodi@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-04-04 13:14:31 +0000
committerfgodi <fgodi@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-04-04 13:14:31 +0000
commitfa1ff1284f51341d452b6adc3a667d13a5d35747 (patch)
treeacad49f44643f6ed5f69707377732790ef463ada /CMakeLists.txt
parent42a123c74255be2e2471eb35fd9226ceea5a011c (diff)
cmake lists
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/bottleneckDistance@1092 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 77b2a427cb3ff80b9a0c5d1c71f9f1de11547530
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 15 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f30c1785..6ed0aedd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -42,7 +42,6 @@ if (GPROF_PATH)
message("gprof found in ${GPROF_PATH}")
endif()
-
if(NOT Boost_FOUND)
message(FATAL_ERROR "NOTICE: This demo requires Boost and will not be compiled.")
else()
@@ -75,12 +74,24 @@ else()
add_subdirectory(src/Hasse_complex/example)
add_subdirectory(src/Alpha_shapes/example)
add_subdirectory(src/Alpha_shapes/test)
- add_subdirectory(src/Bottleneck/example)
- add_subdirectory(src/Bottleneck/test)
+ add_subdirectory(src/Bipartite_graphs_matching/example)
+ add_subdirectory(src/Bipartite_graphs_matching/test)
# data points generator
add_subdirectory(data/points/generator)
-endif()
+endif()
+include( ${CGAL_USE_FILE} )
+# In CMakeLists.txt, when include(${CGAL_USE_FILE}), CXX_FLAGS are overwritten.
+# cf. http://doc.cgal.org/latest/Manual/installation.html#title40
+# A workaround is to add "-std=c++11" again.
+if(NOT MSVC)
+include(CheckCXXCompilerFlag)
+CHECK_CXX_COMPILER_FLAG(-std=c++11 COMPILER_SUPPORTS_CXX11)
+if(COMPILER_SUPPORTS_CXX11)
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+endif()
+endif()
+# - End of workaround