summaryrefslogtreecommitdiff
path: root/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2022-01-14 09:49:57 +0100
committerGard Spreemann <gspr@nonempty.org>2022-01-14 09:49:57 +0100
commitb32f71f0cee1f8609cfb4205bddea088c4e4094b (patch)
tree9a8f04863ed0b82b11228ff44e55ec6ff4c39431 /debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
parent415403affce5dc7fdb63aab3b98f9acfadd063a1 (diff)
Rebase patches
Diffstat (limited to 'debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch')
-rw-r--r--debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch66
1 files changed, 13 insertions, 53 deletions
diff --git a/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch b/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
index 6151ae79..82abd0ed 100644
--- a/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
+++ b/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
@@ -3,12 +3,10 @@ Date: Wed, 25 Sep 2019 15:12:45 +0200
Subject: Disable tests that use DFSG-deleted data files.
---
- src/Nerve_GIC/example/CMakeLists.txt | 5 ----
- src/Nerve_GIC/utilities/CMakeLists.txt | 8 ------
- src/Persistent_cohomology/example/CMakeLists.txt | 12 ---------
- src/Simplex_tree/example/CMakeLists.txt | 2 --
- src/python/CMakeLists.txt | 31 +-----------------------
- 5 files changed, 1 insertion(+), 57 deletions(-)
+ src/Nerve_GIC/example/CMakeLists.txt | 5 -----
+ src/Nerve_GIC/utilities/CMakeLists.txt | 8 --------
+ src/python/CMakeLists.txt | 29 -----------------------------
+ 3 files changed, 42 deletions(-)
diff --git a/src/Nerve_GIC/example/CMakeLists.txt b/src/Nerve_GIC/example/CMakeLists.txt
index 4b0f467..110212d 100644
@@ -48,49 +46,13 @@ index 65a08d9..3f16db9 100644
install(TARGETS Nerve DESTINATION bin)
install(TARGETS VoronoiGIC DESTINATION bin)
-diff --git a/src/Persistent_cohomology/example/CMakeLists.txt b/src/Persistent_cohomology/example/CMakeLists.txt
-index c68c652..9a15a89 100644
---- a/src/Persistent_cohomology/example/CMakeLists.txt
-+++ b/src/Persistent_cohomology/example/CMakeLists.txt
-@@ -33,18 +33,6 @@ if(TARGET Boost::program_options)
- "${CMAKE_SOURCE_DIR}/data/points/Kl.off" "-r" "0.16" "-d" "3" "-p" "3" "-m" "100")
- endif()
-
--if(TARGET Boost::program_options)
-- add_executable(persistence_from_file persistence_from_file.cpp)
-- target_link_libraries(persistence_from_file Boost::program_options)
-- if (TBB_FOUND)
-- target_link_libraries(persistence_from_file ${TBB_LIBRARIES})
-- endif()
-- add_test(NAME Persistent_cohomology_example_from_file_3_2_0 COMMAND $<TARGET_FILE:persistence_from_file>
-- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "2" "-m" "0")
-- add_test(NAME Persistent_cohomology_example_from_file_3_3_100 COMMAND $<TARGET_FILE:persistence_from_file>
-- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "3" "-m" "100")
--endif()
--
- if(GMP_FOUND)
- if(GMPXX_FOUND)
- if(TARGET Boost::program_options)
-diff --git a/src/Simplex_tree/example/CMakeLists.txt b/src/Simplex_tree/example/CMakeLists.txt
-index 73b2c6f..a6dd0b1 100644
---- a/src/Simplex_tree/example/CMakeLists.txt
-+++ b/src/Simplex_tree/example/CMakeLists.txt
-@@ -28,8 +28,6 @@ if(GMP_FOUND AND NOT CGAL_VERSION VERSION_LESS 4.11.0)
- if (TBB_FOUND)
- target_link_libraries(Simplex_tree_example_alpha_shapes_3_from_off ${TBB_LIBRARIES})
- endif()
-- add_test(NAME Simplex_tree_example_alpha_shapes_3_from_off COMMAND $<TARGET_FILE:Simplex_tree_example_alpha_shapes_3_from_off>
-- "${CMAKE_SOURCE_DIR}/data/points/bunny_5000.off")
-
- endif()
-
diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
-index 5c1402a..a45e13a 100644
+index 1314b44..7edac67 100644
--- a/src/python/CMakeLists.txt
+++ b/src/python/CMakeLists.txt
-@@ -386,36 +386,7 @@ if(PYTHONINTERP_FOUND)
- add_gudhi_py_test(test_bottleneck_distance)
- endif()
+@@ -414,35 +414,6 @@ if(PYTHONINTERP_FOUND)
+
+ add_gudhi_py_test(test_bottleneck_distance)
- # Cover complex
- file(COPY ${CMAKE_SOURCE_DIR}/data/points/human.off DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
@@ -98,31 +60,29 @@ index 5c1402a..a45e13a 100644
- file(COPY ${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1 DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
- add_test(NAME cover_complex_nerve_example_py_test
- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
-- COMMAND ${CMAKE_COMMAND} -E env "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}"
+- COMMAND ${CMAKE_COMMAND} -E env "${GUDHI_PYTHON_PATH_ENV}"
- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/nerve_of_a_covering.py"
- -f human.off -c 2 -r 10 -g 0.3)
-
- add_test(NAME cover_complex_coordinate_gic_example_py_test
- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
-- COMMAND ${CMAKE_COMMAND} -E env "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}"
+- COMMAND ${CMAKE_COMMAND} -E env "${GUDHI_PYTHON_PATH_ENV}"
- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/coordinate_graph_induced_complex.py"
- -f human.off -c 0 -v)
-
- add_test(NAME cover_complex_functional_gic_example_py_test
- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
-- COMMAND ${CMAKE_COMMAND} -E env "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}"
+- COMMAND ${CMAKE_COMMAND} -E env "${GUDHI_PYTHON_PATH_ENV}"
- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/functional_graph_induced_complex.py"
- -o lucky_cat.off
- -f lucky_cat_PCA1 -v)
-
- add_test(NAME cover_complex_voronoi_gic_example_py_test
- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
-- COMMAND ${CMAKE_COMMAND} -E env "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}"
+- COMMAND ${CMAKE_COMMAND} -E env "${GUDHI_PYTHON_PATH_ENV}"
- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/voronoi_graph_induced_complex.py"
- -f human.off -n 700 -v)
-
-- add_gudhi_py_test(test_cover_complex)
-+
+ add_gudhi_py_test(test_cover_complex)
endif (NOT CGAL_VERSION VERSION_LESS 4.11.0)
- if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)