summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorGard Spreemann <gspreemann@gmail.com>2018-02-05 10:27:17 +0100
committerGard Spreemann <gspreemann@gmail.com>2018-02-05 10:27:17 +0100
commit0c169783d8d637f9cfcdd4527de0d9d7563cf271 (patch)
treedb52f77f6171a4afb11c420592dab7b67f36b603 /debian/patches
parentba5c3c6591c9d6410f45d012d9ce15bc2f54bb61 (diff)
Refresh patches.
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/0001-Force-Python-3-detection-to-avoid-mixing-2-and-3.patch4
-rw-r--r--debian/patches/0002-Disable-the-Sphinx-test.-We-re-not-using-it-as-it-re.patch4
-rw-r--r--debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch68
-rw-r--r--debian/patches/0004-Use-system-MathJax.patch8
-rw-r--r--debian/patches/0005-Don-t-set-runtime_library_dirs-for-the-Python-extens.patch6
5 files changed, 69 insertions, 21 deletions
diff --git a/debian/patches/0001-Force-Python-3-detection-to-avoid-mixing-2-and-3.patch b/debian/patches/0001-Force-Python-3-detection-to-avoid-mixing-2-and-3.patch
index b6e05ed7..ba76ed11 100644
--- a/debian/patches/0001-Force-Python-3-detection-to-avoid-mixing-2-and-3.patch
+++ b/debian/patches/0001-Force-Python-3-detection-to-avoid-mixing-2-and-3.patch
@@ -1,7 +1,7 @@
-From e92363ab8125cff24a9c2ef5eec159ff09afc381 Mon Sep 17 00:00:00 2001
+From 976e231e80eeb59c27f2389fb9ee70030c56cb44 Mon Sep 17 00:00:00 2001
From: Gard Spreemann <gspreemann@gmail.com>
Date: Mon, 9 Oct 2017 11:46:06 +0200
-Subject: [PATCH 1/4] Force Python 3 detection to avoid mixing 2 and 3.
+Subject: [PATCH 1/5] Force Python 3 detection to avoid mixing 2 and 3.
---
cmake/modules/FindCython.cmake | 6 +++---
diff --git a/debian/patches/0002-Disable-the-Sphinx-test.-We-re-not-using-it-as-it-re.patch b/debian/patches/0002-Disable-the-Sphinx-test.-We-re-not-using-it-as-it-re.patch
index 2eb76f06..b532ab10 100644
--- a/debian/patches/0002-Disable-the-Sphinx-test.-We-re-not-using-it-as-it-re.patch
+++ b/debian/patches/0002-Disable-the-Sphinx-test.-We-re-not-using-it-as-it-re.patch
@@ -1,7 +1,7 @@
-From 2511e115a28311263e7ed85e98296c6af12ea960 Mon Sep 17 00:00:00 2001
+From 598ac8ccc13024583e51f25559cbe7eaf059188e Mon Sep 17 00:00:00 2001
From: Gard Spreemann <gspreemann@gmail.com>
Date: Mon, 9 Oct 2017 12:05:01 +0200
-Subject: [PATCH 2/4] Disable the Sphinx test. We're not using it, as it
+Subject: [PATCH 2/5] Disable the Sphinx test. We're not using it, as it
requires the Sphinx bibtex module (#800358).
---
diff --git a/debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch b/debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch
index eade3da7..54c13639 100644
--- a/debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch
+++ b/debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch
@@ -1,19 +1,45 @@
-From f31347031ea99c60d11064ec28bc27805b5c28b9 Mon Sep 17 00:00:00 2001
+From 9218bee33900e1e203991607e038f029a2216c3c Mon Sep 17 00:00:00 2001
From: Gard Spreemann <gspreemann@gmail.com>
-Date: Mon, 9 Oct 2017 14:15:02 +0200
-Subject: [PATCH 3/4] Disable tests that use DFSG-deleted data files.
+Date: Mon, 5 Feb 2018 10:15:40 +0100
+Subject: [PATCH 3/5] Disable tests that use DFSG-deleted data files.
---
- example/Persistent_cohomology/CMakeLists.txt | 8 ++++----
- example/Simplex_tree/CMakeLists.txt | 4 ++--
- example/common/CMakeLists.txt | 4 ++--
- 3 files changed, 8 insertions(+), 8 deletions(-)
+ example/Nerve_GIC/CMakeLists.txt | 10 +++++-----
+ example/Persistent_cohomology/CMakeLists.txt | 8 ++++----
+ example/Simplex_tree/CMakeLists.txt | 4 ++--
+ example/common/CMakeLists.txt | 4 ++--
+ utilities/Nerve_GIC/CMakeLists.txt | 10 +++++-----
+ 5 files changed, 18 insertions(+), 18 deletions(-)
+diff --git a/example/Nerve_GIC/CMakeLists.txt b/example/Nerve_GIC/CMakeLists.txt
+index f262692..825974c 100644
+--- a/example/Nerve_GIC/CMakeLists.txt
++++ b/example/Nerve_GIC/CMakeLists.txt
+@@ -13,14 +13,14 @@ if (NOT CGAL_VERSION VERSION_LESS 4.8.1)
+
+ # Copy files for not to pollute sources when testing
+ file(COPY "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
++ #file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
++ #file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+
+ add_test(NAME Nerve_GIC_example_CoordGIC COMMAND $<TARGET_FILE:CoordGIC>
+ "tore3D_1307.off" "0")
+
+- add_test(NAME Nerve_GIC_example_FuncGIC COMMAND $<TARGET_FILE:FuncGIC>
+- "lucky_cat.off"
+- "lucky_cat_PCA1")
++ #add_test(NAME Nerve_GIC_example_FuncGIC COMMAND $<TARGET_FILE:FuncGIC>
++ # "lucky_cat.off"
++ # "lucky_cat_PCA1")
+
+ endif (NOT CGAL_VERSION VERSION_LESS 4.8.1)
diff --git a/example/Persistent_cohomology/CMakeLists.txt b/example/Persistent_cohomology/CMakeLists.txt
-index f47de4c..8f11ea0 100644
+index 18e2913..e2dca6d 100644
--- a/example/Persistent_cohomology/CMakeLists.txt
+++ b/example/Persistent_cohomology/CMakeLists.txt
-@@ -41,10 +41,10 @@ add_test(NAME Persistent_cohomology_example_from_rips_step_by_step_on_tore_3D CO
+@@ -29,10 +29,10 @@ add_test(NAME Persistent_cohomology_example_from_rips_step_by_step_on_tore_3D CO
"${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" "-r" "0.25" "-m" "0.5" "-d" "3" "-p" "3")
add_test(NAME Persistent_cohomology_example_via_boundary_matrix COMMAND $<TARGET_FILE:rips_persistence_via_boundary_matrix>
"${CMAKE_SOURCE_DIR}/data/points/Kl.off" "-r" "0.16" "-d" "3" "-p" "3" "-m" "100")
@@ -29,7 +55,7 @@ index f47de4c..8f11ea0 100644
install(TARGETS plain_homology DESTINATION bin)
install(TARGETS persistence_from_simple_simplex_tree DESTINATION bin)
diff --git a/example/Simplex_tree/CMakeLists.txt b/example/Simplex_tree/CMakeLists.txt
-index e22cc92..99da80f 100644
+index b33b2d0..1cba524 100644
--- a/example/Simplex_tree/CMakeLists.txt
+++ b/example/Simplex_tree/CMakeLists.txt
@@ -30,8 +30,8 @@ if(GMP_FOUND AND CGAL_FOUND)
@@ -58,6 +84,28 @@ index afe865d..2ad4a64 100644
install(TARGETS vector_double_off_reader DESTINATION bin)
+diff --git a/utilities/Nerve_GIC/CMakeLists.txt b/utilities/Nerve_GIC/CMakeLists.txt
+index 7762c8a..c41898b 100644
+--- a/utilities/Nerve_GIC/CMakeLists.txt
++++ b/utilities/Nerve_GIC/CMakeLists.txt
+@@ -13,12 +13,12 @@ if (NOT CGAL_VERSION VERSION_LESS 4.8.1)
+
+ file(COPY KeplerMapperVisuFromTxtFile.py km.py DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+ # Copy files for not to pollute sources when testing
+- file(COPY "${CMAKE_SOURCE_DIR}/data/points/human.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
++ #file(COPY "${CMAKE_SOURCE_DIR}/data/points/human.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+
+- add_test(NAME Nerve_GIC_utilities_nerve COMMAND $<TARGET_FILE:Nerve>
+- "human.off" "2" "10" "0.3")
++ #add_test(NAME Nerve_GIC_utilities_nerve COMMAND $<TARGET_FILE:Nerve>
++ # "human.off" "2" "10" "0.3")
+
+- add_test(NAME Nerve_GIC_utilities_VoronoiGIC COMMAND $<TARGET_FILE:VoronoiGIC>
+- "human.off" "100")
++ #add_test(NAME Nerve_GIC_utilities_VoronoiGIC COMMAND $<TARGET_FILE:VoronoiGIC>
++ # "human.off" "100")
+
+ endif (NOT CGAL_VERSION VERSION_LESS 4.8.1)
--
2.11.0
diff --git a/debian/patches/0004-Use-system-MathJax.patch b/debian/patches/0004-Use-system-MathJax.patch
index 916d23b9..98510981 100644
--- a/debian/patches/0004-Use-system-MathJax.patch
+++ b/debian/patches/0004-Use-system-MathJax.patch
@@ -1,17 +1,17 @@
-From 46fdbaf1a91c320d7f731d061ef6d8d6da73232a Mon Sep 17 00:00:00 2001
+From 1228db48dd680c1baf20fdd9b5b99665adf8f212 Mon Sep 17 00:00:00 2001
From: Gard Spreemann <gspreemann@gmail.com>
Date: Mon, 9 Oct 2017 16:06:36 +0200
-Subject: [PATCH 4/4] Use system MathJax.
+Subject: [PATCH 4/5] Use system MathJax.
---
Doxyfile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Doxyfile b/Doxyfile
-index 0ef81e5..51df82e 100644
+index f1981e2..991645b 100644
--- a/Doxyfile
+++ b/Doxyfile
-@@ -1450,7 +1450,7 @@ MATHJAX_FORMAT = HTML-CSS
+@@ -1453,7 +1453,7 @@ MATHJAX_FORMAT = HTML-CSS
# The default value is: http://cdn.mathjax.org/mathjax/latest.
# This tag requires that the tag USE_MATHJAX is set to YES.
diff --git a/debian/patches/0005-Don-t-set-runtime_library_dirs-for-the-Python-extens.patch b/debian/patches/0005-Don-t-set-runtime_library_dirs-for-the-Python-extens.patch
index c5677149..ace45b46 100644
--- a/debian/patches/0005-Don-t-set-runtime_library_dirs-for-the-Python-extens.patch
+++ b/debian/patches/0005-Don-t-set-runtime_library_dirs-for-the-Python-extens.patch
@@ -1,7 +1,7 @@
-From 2dfc0e89fdf40fe474ef0ec2018fe06e5eb786d5 Mon Sep 17 00:00:00 2001
+From 8beaad20e6d61f9d2253ee1b679fe2feafff9bdc Mon Sep 17 00:00:00 2001
From: Gard Spreemann <gspreemann@gmail.com>
Date: Mon, 16 Oct 2017 13:46:22 +0200
-Subject: [PATCH] Don't set runtime_library_dirs for the Python extension.
+Subject: [PATCH 5/5] Don't set runtime_library_dirs for the Python extension.
Avoid RPATH in the shared object.
---
@@ -9,7 +9,7 @@ Subject: [PATCH] Don't set runtime_library_dirs for the Python extension.
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/cython/setup.py.in b/cython/setup.py.in
-index fefa36b..18d03ad 100644
+index c767e93..d00f65a 100644
--- a/cython/setup.py.in
+++ b/cython/setup.py.in
@@ -36,7 +36,7 @@ gudhi = Extension(