summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorGard Spreemann <gspreemann@gmail.com>2017-04-21 13:29:58 +0200
committerGard Spreemann <gspreemann@gmail.com>2017-04-21 14:06:49 +0200
commitb1d675fa67b6ea2c69d2667c179058fe4d4a5f00 (patch)
tree41711aec55196b10614c46c6f66a6ad975803e49 /debian/patches
parent1c46403a1630cfde31807546066226e5647f839f (diff)
Add patch to disable a test that uncleanly writes outside of the build directory.
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/0001-Disable-some-tests-that-uncleanly-write-outside-of-t.patch51
-rw-r--r--debian/patches/series2
2 files changed, 52 insertions, 1 deletions
diff --git a/debian/patches/0001-Disable-some-tests-that-uncleanly-write-outside-of-t.patch b/debian/patches/0001-Disable-some-tests-that-uncleanly-write-outside-of-t.patch
new file mode 100644
index 00000000..463e13d1
--- /dev/null
+++ b/debian/patches/0001-Disable-some-tests-that-uncleanly-write-outside-of-t.patch
@@ -0,0 +1,51 @@
+From 1ecf2bf414b0cacf43fb05e4ba33528c7cfc04a1 Mon Sep 17 00:00:00 2001
+From: Gard Spreemann <gspreemann@gmail.com>
+Date: Fri, 21 Apr 2017 11:55:21 +0200
+Subject: [PATCH] Disable some tests that uncleanly write outside of the build
+ directory.
+
+---
+ example/Bitmap_cubical_complex/CMakeLists.txt | 21 +++++++++++----------
+ 1 file changed, 11 insertions(+), 10 deletions(-)
+
+diff --git a/example/Bitmap_cubical_complex/CMakeLists.txt b/example/Bitmap_cubical_complex/CMakeLists.txt
+index 241a11e..82fd911 100644
+--- a/example/Bitmap_cubical_complex/CMakeLists.txt
++++ b/example/Bitmap_cubical_complex/CMakeLists.txt
+@@ -7,11 +7,11 @@ if (TBB_FOUND)
+ target_link_libraries(Bitmap_cubical_complex ${TBB_LIBRARIES})
+ endif()
+
+-add_test(NAME Bitmap_cubical_complex_example_persistence_one_sphere COMMAND $<TARGET_FILE:Bitmap_cubical_complex>
+- "${CMAKE_SOURCE_DIR}/data/bitmap/CubicalOneSphere.txt")
++#add_test(NAME Bitmap_cubical_complex_example_persistence_one_sphere COMMAND $<TARGET_FILE:Bitmap_cubical_complex>
++# "${CMAKE_SOURCE_DIR}/data/bitmap/CubicalOneSphere.txt")
+
+-add_test(NAME Bitmap_cubical_complex_example_persistence_two_sphere COMMAND $<TARGET_FILE:Bitmap_cubical_complex>
+- "${CMAKE_SOURCE_DIR}/data/bitmap/CubicalTwoSphere.txt")
++#add_test(NAME Bitmap_cubical_complex_example_persistence_two_sphere COMMAND $<TARGET_FILE:Bitmap_cubical_complex>
++# "${CMAKE_SOURCE_DIR}/data/bitmap/CubicalTwoSphere.txt")
+
+ add_executable ( Random_bitmap_cubical_complex Random_bitmap_cubical_complex.cpp )
+ target_link_libraries(Random_bitmap_cubical_complex ${Boost_SYSTEM_LIBRARY})
+@@ -27,10 +27,11 @@ if (TBB_FOUND)
+ target_link_libraries(Bitmap_cubical_complex_periodic_boundary_conditions ${TBB_LIBRARIES})
+ endif()
+
+-add_test(NAME Bitmap_cubical_complex_example_periodic_boundary_conditions_2d_torus
+- COMMAND $<TARGET_FILE:Bitmap_cubical_complex_periodic_boundary_conditions>
+- "${CMAKE_SOURCE_DIR}/data/bitmap/2d_torus.txt")
++#add_test(NAME Bitmap_cubical_complex_example_periodic_boundary_conditions_2d_torus
++# COMMAND $<TARGET_FILE:Bitmap_cubical_complex_periodic_boundary_conditions>
++# "${CMAKE_SOURCE_DIR}/data/bitmap/2d_torus.txt")
+
+-add_test(NAME Bitmap_cubical_complex_example_periodic_boundary_conditions_3d_torus
+- COMMAND $<TARGET_FILE:Bitmap_cubical_complex_periodic_boundary_conditions>
+- "${CMAKE_SOURCE_DIR}/data/bitmap/3d_torus.txt")
++#add_test(NAME Bitmap_cubical_complex_example_periodic_boundary_conditions_3d_torus
++# COMMAND $<TARGET_FILE:Bitmap_cubical_complex_periodic_boundary_conditions>
++# "${CMAKE_SOURCE_DIR}/data/bitmap/3d_torus.txt")
++
+--
+2.11.0
+
diff --git a/debian/patches/series b/debian/patches/series
index 8b137891..3b2c6c02 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1 @@
-
+0001-Disable-some-tests-that-uncleanly-write-outside-of-t.patch