summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorGard Spreemann <gspreemann@gmail.com>2017-04-21 11:20:34 +0200
committerGard Spreemann <gspreemann@gmail.com>2017-04-21 14:02:51 +0200
commitceb350bc51f7162c763de072a65745bf58c82cc0 (patch)
tree5e312a49dd1094fac5cfee177a3ce3f587a4625c /debian/patches
parentceb7b895f38b91c78c72fab597952e293fb6fab7 (diff)
Remove old patches.
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/0001-Stash-flags.patch32
-rw-r--r--debian/patches/0002-Don-t-use-static-boost.patch21
-rw-r--r--debian/patches/0003-Disable-some-tests-that-uncleanly-write-outside-the-.patch32
-rw-r--r--debian/patches/series4
4 files changed, 1 insertions, 88 deletions
diff --git a/debian/patches/0001-Stash-flags.patch b/debian/patches/0001-Stash-flags.patch
deleted file mode 100644
index db45a7e6..00000000
--- a/debian/patches/0001-Stash-flags.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From: Gard Spreemann <gspreemann@gmail.com>
-Date: Thu, 13 Oct 2016 15:43:54 +0200
-Subject: Stash flags.
-
----
- CMakeLists.txt | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index cde949e..a1b39c3 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -36,6 +36,8 @@ else()
- # A fix would be to use https://cmake.org/cmake/help/v3.1/prop_gbl/CMAKE_CXX_KNOWN_FEATURES.html
- # or even better https://cmake.org/cmake/help/v3.1/variable/CMAKE_CXX_STANDARD.html
- # but it implies to use cmake version 3.1 at least.
-+ set(STASH_CXXFLAGS "${CMAKE_CXX_FLAGS}")
-+ set(STASH_LDFLAGS "${CMAKE_SHARED_LINKER_FLAGS}")
-
- # find CGAL in QUIET mode for cmake to be less verbose when CGAL is not found.
- find_package(CGAL QUIET)
-@@ -53,8 +55,9 @@ else()
- # Turn off some VC++ warnings
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /wd4267 /wd4668 /wd4311 /wd4800 /wd4820 /wd4503 /wd4244 /wd4345 /wd4996 /wd4396 /wd4018")
- else()
-- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall -Wpedantic -Wsign-compare")
-+ set(CMAKE_CXX_FLAGS "-std=c++11 ${STASH_CXXFLAGS}")
- endif()
-+ set(CMAKE_SHARED_LINKER_FLAGS "${STASH_LDFLAGS}")
-
- if(CMAKE_BUILD_TYPE MATCHES Debug)
- message("++ Debug compilation flags are: ${CMAKE_CXX_FLAGS} ${CMAKE_CXX_FLAGS_DEBUG}")
diff --git a/debian/patches/0002-Don-t-use-static-boost.patch b/debian/patches/0002-Don-t-use-static-boost.patch
deleted file mode 100644
index 44ca1ac3..00000000
--- a/debian/patches/0002-Don-t-use-static-boost.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From: Gard Spreemann <gspreemann@gmail.com>
-Date: Fri, 14 Oct 2016 10:31:08 +0200
-Subject: Don't use static boost.
-
----
- CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index a1b39c3..0f349f8 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -65,7 +65,7 @@ else()
- message("++ Release compilation flags are: ${CMAKE_CXX_FLAGS} ${CMAKE_CXX_FLAGS_RELEASE}")
- endif()
-
-- set(Boost_USE_STATIC_LIBS ON)
-+ set(Boost_USE_STATIC_LIBS OFF)
- set(Boost_USE_MULTITHREADED ON)
- set(Boost_USE_STATIC_RUNTIME OFF)
-
diff --git a/debian/patches/0003-Disable-some-tests-that-uncleanly-write-outside-the-.patch b/debian/patches/0003-Disable-some-tests-that-uncleanly-write-outside-the-.patch
deleted file mode 100644
index 75a4420c..00000000
--- a/debian/patches/0003-Disable-some-tests-that-uncleanly-write-outside-the-.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From: Gard Spreemann <gspreemann@gmail.com>
-Date: Fri, 14 Oct 2016 11:04:19 +0200
-Subject: Disable some tests that uncleanly write outside the build directory.
-
----
- example/Bitmap_cubical_complex/CMakeLists.txt | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/example/Bitmap_cubical_complex/CMakeLists.txt b/example/Bitmap_cubical_complex/CMakeLists.txt
-index 2fddc51..eb9990b 100644
---- a/example/Bitmap_cubical_complex/CMakeLists.txt
-+++ b/example/Bitmap_cubical_complex/CMakeLists.txt
-@@ -6,8 +6,8 @@ target_link_libraries(Bitmap_cubical_complex ${Boost_SYSTEM_LIBRARY})
- if (TBB_FOUND)
- target_link_libraries(Bitmap_cubical_complex ${TBB_LIBRARIES})
- endif()
--add_test(Bitmap_cubical_complex_one_sphere ${CMAKE_CURRENT_BINARY_DIR}/Bitmap_cubical_complex ${CMAKE_SOURCE_DIR}/data/bitmap/CubicalOneSphere.txt)
--add_test(Bitmap_cubical_complex_two_sphere ${CMAKE_CURRENT_BINARY_DIR}/Bitmap_cubical_complex ${CMAKE_SOURCE_DIR}/data/bitmap/CubicalTwoSphere.txt)
-+#add_test(Bitmap_cubical_complex_one_sphere ${CMAKE_CURRENT_BINARY_DIR}/Bitmap_cubical_complex ${CMAKE_SOURCE_DIR}/data/bitmap/CubicalOneSphere.txt)
-+#add_test(Bitmap_cubical_complex_two_sphere ${CMAKE_CURRENT_BINARY_DIR}/Bitmap_cubical_complex ${CMAKE_SOURCE_DIR}/data/bitmap/CubicalTwoSphere.txt)
-
- add_executable ( Random_bitmap_cubical_complex Random_bitmap_cubical_complex.cpp )
- target_link_libraries(Random_bitmap_cubical_complex ${Boost_SYSTEM_LIBRARY})
-@@ -21,6 +21,6 @@ target_link_libraries(Bitmap_cubical_complex_periodic_boundary_conditions ${Boos
- if (TBB_FOUND)
- target_link_libraries(Bitmap_cubical_complex_periodic_boundary_conditions ${TBB_LIBRARIES})
- endif()
--add_test(Bitmap_cubical_complex_periodic_2d_torus ${CMAKE_CURRENT_BINARY_DIR}/Bitmap_cubical_complex_periodic_boundary_conditions ${CMAKE_SOURCE_DIR}/data/bitmap/2d_torus.txt)
--add_test(Bitmap_cubical_complex_periodic_3d_torus ${CMAKE_CURRENT_BINARY_DIR}/Bitmap_cubical_complex_periodic_boundary_conditions ${CMAKE_SOURCE_DIR}/data/bitmap/3d_torus.txt)
-+#add_test(Bitmap_cubical_complex_periodic_2d_torus ${CMAKE_CURRENT_BINARY_DIR}/Bitmap_cubical_complex_periodic_boundary_conditions ${CMAKE_SOURCE_DIR}/data/bitmap/2d_torus.txt)
-+#add_test(Bitmap_cubical_complex_periodic_3d_torus ${CMAKE_CURRENT_BINARY_DIR}/Bitmap_cubical_complex_periodic_boundary_conditions ${CMAKE_SOURCE_DIR}/data/bitmap/3d_torus.txt)
-
diff --git a/debian/patches/series b/debian/patches/series
index 093461ad..8b137891 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1 @@
-0001-Stash-flags.patch
-0002-Don-t-use-static-boost.patch
-0003-Disable-some-tests-that-uncleanly-write-outside-the-.patch
+