summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGard Spreemann <gspreemann@gmail.com>2017-04-30 15:05:44 +0200
committerGard Spreemann <gspreemann@gmail.com>2017-04-30 15:05:44 +0200
commit506d7ced5520c3d73d5ef2fc7a33b796a0668ee8 (patch)
tree48f60942a68b6dbead5ef923afd8032399f8f7bf /debian/rules
parent318ec700b330aaf722f19626647fe0a56375cd9d (diff)
Do build-time tests sequentually. Some of the "diff" tests fail nondeterministically if run in parallel.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules3
1 files changed, 3 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 124fae7b..7e9ba1ec 100755
--- a/debian/rules
+++ b/debian/rules
@@ -19,6 +19,9 @@ override_dh_auto_build:
make -C build doxygen
dh_auto_build
+override_dh_auto_test:
+ dh_auto_test --no-parallel --builddirectory=build
+
override_dh_auto_install:
find build/example -executable -type f -exec sh -c 'install -D $$0 debian/tmp/usr/bin/libgudhi-example-$$(basename $$0)' {} \;
find example -type f \( -name '*.cpp' -o \( -name '*.txt' -a ! -iname 'cmake*' \) \) -exec sh -c 'install -D -m 644 $$0 debian/tmp/usr/share/doc/libgudhi-examples/$$0' {} \;