summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2019-10-22 15:16:14 +0200
committerGard Spreemann <gspr@nonempty.org>2019-10-22 15:16:14 +0200
commit811b90d7e04c07ec0a31d3068d380324908e8665 (patch)
treea62da3e8432206884179bfcbb7ec365ff1c5db9f /debian/rules
parent3c20574b2a11b9c2a3f8cdbadbce375d9540d096 (diff)
Let CMake control everything.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 4 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 155e12c1..5a0d0ba3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,6 +11,8 @@ PY3VERS:=$(shell py3versions -vs)
DEFAULT_PY3VER=$(shell py3versions -vd)
REMAINING_PY3VERS:=$(filter-out $(DEFAULT_PY3VER), $(PY3VERS))
+DHFLAGS+=--buildsystem=cmake
+
# The buildds run out of memory on some architectures. On those, we
# force non-parallel building.
ifneq (, $(filter $(shell dpkg-architecture --query DEB_BUILD_ARCH),mips mipsel m68k powerpcspe))
@@ -21,9 +23,9 @@ endif
%:
# The --buildirectory=build is there so that we can easily get a hold
# of documentation and examples, which are not installed by upstream.
- dh $@ $(DHFLAGS) --with=python3 --builddirectory=build
+ dh $@ $(DHFLAGS) --builddirectory=build
for py3ver in $(REMAINING_PY3VERS) ; do \
- dh $@ $(DHFLAGS) --with=python3 --builddirectory=build$$py3ver ; \
+ dh $@ $(DHFLAGS) --builddirectory=build$$py3ver ; \
done
override_dh_auto_configure: