summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGard Spreemann <gspreemann@gmail.com>2017-02-12 18:19:58 +0100
committerGard Spreemann <gspreemann@gmail.com>2017-02-12 18:23:29 +0100
commit963fdb60064bf44de5bc0a4a45c69017a617f1df (patch)
tree20e7bae64bc98f2dd9324b92caa22fdade31f216 /debian/rules
parent398432fc57bd89efc47f7d2e93a2f7358eedaf42 (diff)
Install examples.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 2bfc3eeb..52551d70 100755
--- a/debian/rules
+++ b/debian/rules
@@ -19,5 +19,8 @@ override_dh_auto_build:
make -C build doxygen
dh_auto_build
-
+override_dh_auto_install:
+ find build/example -executable -type f -exec sh -c 'install -D $$0 debian/tmp/usr/bin/libgudhi-example-$$(basename $$0)' {} \;
+ find example -type f \( -name '*.cpp' -o \( -name '*.txt' -a ! -iname 'cmake*' \) \) -exec sh -c 'install -D -m 644 $$0 debian/tmp/usr/share/doc/libgudhi-examples/$$0' {} \;
+ dh_auto_install