summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGard Spreemann <gspreemann@gmail.com>2017-02-09 23:40:04 +0100
committerGard Spreemann <gspreemann@gmail.com>2017-02-09 23:40:04 +0100
commit9f6e9a51c2fba32ea2373aee7e2879c22bb8a0e5 (patch)
treec24d7e4d71f642292fc2d40202a23dd9c44cd1d4 /debian/rules
parentcb10b2712269194fe151a48a88ed607732945ad2 (diff)
Build documentation package libgudhi-doc.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 7 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 966071e5..2bfc3eeb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,14 +6,18 @@ CXXFLAGS:=$(shell dpkg-buildflags --get CXXFLAGS)
LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
%:
- dh $@
+# The --buildirectory=build is there so that we can easily get a hold
+# of documentation and examples, which are not installed by upstream.
+ dh $@ --builddirectory=build
override_dh_auto_clean:
rm -f GUDHIVersion.cmake
+ rm -rf doc/html
dh_auto_clean
-override_dh_auto_install:
- dh_auto_install --destdir=debian/tmp/
+override_dh_auto_build:
+ make -C build doxygen
+ dh_auto_build