summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGard Spreemann <gspreemann@gmail.com>2017-02-07 17:39:51 +0100
committerGard Spreemann <gspreemann@gmail.com>2017-02-07 17:39:51 +0100
commitb2ef701685b7d19fbaac1529a0bc553da9e29308 (patch)
treeaf02b6477498b3cda439c57665fe40f6e1c810a2 /debian/rules
parent5638527781e1d8cd916cd28f9d375eef7b5d820b (diff)
Initial Debian packaging as uploaded to mentors.debian.net.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules19
1 files changed, 19 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..966071e5
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,19 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
+CXXFLAGS:=$(shell dpkg-buildflags --get CXXFLAGS)
+LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
+
+%:
+ dh $@
+
+override_dh_auto_clean:
+ rm -f GUDHIVersion.cmake
+ dh_auto_clean
+
+override_dh_auto_install:
+ dh_auto_install --destdir=debian/tmp/
+
+
+